Question Is Hyperx Fury 32gb 3600mhz compatible with B550-F Gaming/Ryzen 5800x ?

Jul 2, 2021
14
0
10
0
So i bought a pc with hyperx fury 32gb 3600mhz and b550-f gaming asus motherboard with ryzen 5800x.
and im just wondering if these components are compatible with each other or if i should have gone with different memory sticks. im asking because of recent stuttering issues with my pc....
 

Lutfij

Titan
Moderator
You're good to go. By default the sticks should be running at DDR4-2133Mhz or around that speeds, make sure you're on the latest BIOS update for the motherboard and then manually input timings voltage and frequency in BIOS.
 
Jul 2, 2021
14
0
10
0
You're good to go. By default the sticks should be running at DDR4-2133Mhz or around that speeds, make sure you're on the latest BIOS update for the motherboard and then manually input timings voltage and frequency in BIOS.
so i am on the latest bios version. But i havent put in timings voltage and frequenzy in manually, i just put on DOCP.. what is the difference between doing it manually and enabling DOCP?
 
Last edited:
so i am on the latest bios version. But i havent put in timings voltage and frequenzy in manually, i just put on DOCP.. what is the difference between doing it manually and enabling DOCP?
did you put it on slot 2 and 4? try to get in bios and enable docp then set the voltage manually to 1.35v. try to install amd chipset driver if u didnt install it yet.
 
Jul 2, 2021
14
0
10
0
did you put it on slot 2 and 4? try to get in bios and enable docp then set the voltage manually to 1.35v. try to install amd chipset driver if u didnt install it yet.
Yes it is in slot 2 and 4, i have enabled docp, and the voltage is already set to 1.35. But is there any difference to doing it manually or enabeling it thru docp?
i havent installed amd chipset driver, going to do it now
 
Yes it is in slot 2 and 4, i have enabled docp, and the voltage is already set to 1.35. But is there any difference to doing it manually or enabeling it thru docp?
i havent installed amd chipset driver, going to do it now
well no, but sometimes motherboard could be wacky like it displays it, but when you save the settings it is still on regular speed and voltage, just making sure. Did it run on 3600mhz speed? At what timing? Send an Aida64 on Chipset page and/or cpuz on memory and spd page.
 
Jul 2, 2021
14
0
10
0
well no, but sometimes motherboard could be wacky like it displays it, but when you save the settings it is still on regular speed and voltage, just making sure. Did it run on 3600mhz speed? At what timing? Send an Aida64 on Chipset page and/or cpuz on memory and spd page.
It says in the bios that it is running on 3600mhz but on cpu-z it is at 1800. ive read that u read it as 1800x2 at cpu-z, i might be wrong tho....
I wasnt sure what u wanted me to do, but i think i got the most of it...

 
It says in the bios that it is running on 3600mhz but on cpu-z it is at 1800. ive read that u read it as 1800x2 at cpu-z, i might be wrong tho....
I wasnt sure what u wanted me to do, but i think i got the most of it...

seems normal, what are your specs anyway? did you installed the chipset driver yet? try to uninstall the driver using ddu and install the laatest driver.
 
Jul 2, 2021
14
0
10
0
seems normal, what are your specs anyway? did you installed the chipset driver yet? try to uninstall the driver using ddu and install the laatest driver.
Specs:
Gpu: RTX 3070 tuf gaming 8gb
Cpu: Ryzen 7 5800x
Ram: 32gb 3600mhz
SSD: Samsung 970 evo plus 1tb
Motherboard: B550-F
PSU: corsair 750w

ye i installed the chipset driver. still kinda stuttery...

Im not home atm, so im going to do the ddu thing and reply with how it went :)
 
Specs:
Gpu: RTX 3070 tuf gaming 8gb
Cpu: Ryzen 7 5800x
Ram: 32gb 3600mhz
SSD: Samsung 970 evo plus 1tb
Motherboard: B550-F
PSU: corsair 750w

ye i installed the chipset driver. still kinda stuttery...

Im not home atm, so im going to do the ddu thing and reply with how it went :)
After you installed the chipset driver, go to power plan, and choose AMD Ryzen Balanced power plan.
Also after u did the ddu thing and fresh install the latest driver, open Nvidia control panel, go to manage 3D Settings, and try to match my settings:



for OpenGL gpu just change it to your current GPU. Also for texture filtering you could use the same as me or high quality, tis a RTX XD. Also enable scaling on the very top of the options in the list (not seen in the screenshot i gave). Apply, and give it a run.
 
Jul 2, 2021
14
0
10
0
After you installed the chipset driver, go to power plan, and choose AMD Ryzen Balanced power plan.
Also after u did the ddu thing and fresh install the latest driver, open Nvidia control panel, go to manage 3D Settings, and try to match my settings:



for OpenGL gpu just change it to your current GPU. Also for texture filtering you could use the same as me or high quality, tis a RTX XD. Also enable scaling on the very top of the options in the list (not seen in the screenshot i gave). Apply, and give it a run.
Well i did it, and used ur settings, but not really much happened....
 
Jul 2, 2021
14
0
10
0
hmm, the very last way is clean install windows.
The main drive for ssd must be partioned as GPT, also disable csm option in bios. then do a clean install on the windows.
SSD is GPT
So a little update, i did have a logitech g pro mouse, i switched it out with razer viper, the most pain stutter did go away, but the games still feel very sluggish/laggy, does not feel smooth at all.... but i might give a clean install a try..
 
SSD is GPT
So a little update, i did have a logitech g pro mouse, i switched it out with razer viper, the most pain stutter did go away, but the games still feel very sluggish/laggy, does not feel smooth at all.... but i might give a clean install a try..
I remembered one of my friend complains why his games is also underutilized.

Culprit is the NZXT Cam app and the driver, somehow his 1050ti become wack if overclock applied on afterburner, the gpu will not fully utilized and both core and cpu clock stuck at the lowest power saving mode, not sure if his gpu bios is corrupted, not dare enough to reflash his gpu since its isn't mine. Clean install the driver (like what i told you beore) works, and if he oc again, it will stuck again, reinstall again. He uses R3 3100 + B450M Pro VDH Max combo, still not sure what buggs the device so much.
 
Jul 2, 2021
14
0
10
0
I remembered one of my friend complains why his games is also underutilized.

Culprit is the NZXT Cam app and the driver, somehow his 1050ti become wack if overclock applied on afterburner, the gpu will not fully utilized and both core and cpu clock stuck at the lowest power saving mode, not sure if his gpu bios is corrupted, not dare enough to reflash his gpu since its isn't mine. Clean install the driver (like what i told you beore) works, and if he oc again, it will stuck again, reinstall again. He uses R3 3100 + B450M Pro VDH Max combo, still not sure what buggs the device so much.
Hmmm..
Well i called the vendor and i am going to send my pc for service, to see if they experience the same.. And if they do they will change some of the components out, and if they dont its prob something on my end, internett or monitor or something.. so i hope it gets fixed...
Thx for the help tho
 

mamasan2000

Distinguished
If you change out half the components in your PC, you should do a clean install of Windows. I would suggest you have Windows on 1 partition and the rest of your files elsewhere. You'll thank yourself one day when Windows decides to not boot at all and you have to nuke and pave (reinstall Win).

If in a multiplayer game you run forward for a second and the game then warps you back to where you started, that's internet lag. If the image is choppy, it's your system. I haven't heard of it being the monitor ever.
https://rog.asus.com/motherboards/rog-strix/rog-strix-b550-f-gaming-model/helpdesk_download Get Lan & chipset drivers. Audio (realtek) too if you use onboard audio. The rest you can skip.
I don't know if you are into RGB but stuff like Asus utilities (Armoury Crate) usually are iffy. I always skip em, I've had too many issues.
 

ASK THE COMMUNITY

TRENDING THREADS