Question Is it bricked? x470 black screen after reset

Jan 20, 2019
6
0
10
0
Hi,

I have an Aurous x470 and i was working fine on W10 with the version F4. I saw there was an update to f6 and as some videos I saw that they said that it was important to keep the bios updated i did.

Altough I didn't think that the windows process using the asus utility was so dangerous so I used. Mistake, I know. The process went well, saved the old one and it looks like it download the proper one from the server and it installed. Then it prompted a message saying it needed a reboot. I did and now all i can see it's a back screen. I haven't even turned off yet as I have read so many bad things that I don't know what should be my next step.

No weird noises, no red leds on, and the fans are working. I downloaded the F4 bios to an usb but i haven't tried yet.

Is there anything I should do? I left it on without touching it for around 15 min. I don't think it should stay longer as it's not gonna change.

any advice?

thank you
 
Jan 20, 2019
6
0
10
0
it is an aorus x470 ultra gaming

actually i turned off pressing the power button for few seconds. I turned on and i had the aurus logo, then it reboot and now it works properly with the f6 installed

The GPU tells me that it got the default configuration after a system failure but everything looks good otherwise

i have two ram slots kingston 8gb each at 3200 but the motherboard has them running at 2400. I Haven't activatedthe XRP profile and it the aorus app center i can activate the profile 1 or 2 and the frecuency. Any advice on how to put them up to 3200 ?

I bought this one
https://www.amazon.fr/gp/product/B01GCWQ8VO/ref=ppx_yo_dt_b_asin_title_o08_s00?ie=UTF8&psc=1

thank you!!
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS