Question Is it possible that z490 motherboard does not have a bios update for rocket lake?

Neod!mium

Prominent
Mar 16, 2020
35
1
535
0
I bought myself all the parts to my first computer (that I bought it myself and it's not trash)

So let me say right away what I have:
CPU 11600K
MBO iGame Colorful z490 x v20
RAM2X16gb Trident Z
GPU 1080 Ti
PSU EVGA 750 (W) BQ
2x SSM NVME samsung 0.5 Tb each
2x HDD 1 Tb
Noctua ...
Basic case

I put it all together and when I start the computer it shuts down after a second.

I suspect a power supply but it is not a power supply because I happen to have another power supply.

After I disassembled absolutely the whole computer, I realized that the motherboard (on the box) works on its own when I take out its processor.

It shuts down instantly with the processor.
I also tried clear CMOS and a few little things and everything still the same.

I assumed in the end that the motherboard was not working because the processor was newer than it.

I looked for bios on the page:
https://www.colorful.cn/product_show.aspx?mid=84&id=807

After which I noticed that they don’t have bios for Rocket Lake at all.

I struggled to text them because the website is in Chinese ... I doubt they will have a solution.

Do you have a solution for me, I threw a lot of money on this computer, I'm trying to avoid more costs and I urgently need a PC.

Thanks for reading and understanding

from Croatia :)
 

ASK THE COMMUNITY