Is my 4870 dead?

EAZY-E

Distinguished
Nov 25, 2008
115
0
18,680
I have a huge problem with my 4870. It works fine in the bios, on the windows loading screen, in safemode, and on a normal desktop(without the drivers installed). Once I install the drivers, the card makes it through post, the bootloader and the windows loading screen fine.Unfortunately, were the logion screen should be, I get a blank black screen. The monitor still has input though. Typing in my password and pressing enter does nothing.

Is the card dead?
Is there anyway that I can tell for sure that the card is dead?
If the card isn't dead, what's wrong?
 

EAZY-E

Distinguished
Nov 25, 2008
115
0
18,680
Sorry i have no idea why it quadruple posted! please only reply to the one that i Haven't replyed to.
Thanks.

(don't reply to this one!!)
 
You need to do some more troubleshooting to decide if it's:
a) the HD4870
b) Windows (software glitch)
c) other hardware issue

Before going too far, confirm your graphics card fan is spinning.

Troubleshooting is basically swapping parts around. If you don't have Windows 7 RC, get a copy then unhook your old hard drive and start installing it to another hard drive. If you get into Windows 7, get the latest drivers, install and run a benchmark like 3DMarkxxxx.

I'm a little confused, it seems your card WAS working then you installed drivers and now you have issues?

If so, try going into SAFE MODE (F8 likely), uninstall your current video drivers and see what happens.

Troubleshooting tip:
Don't throw out or give away all your old hardware. Keep enough for future troubleshooting. Usually RAM is no good as the slot changes. Keep an older hard drive, PCIe video card etc.

Other:
- Unhook everything except what is absolutely necessary.
- Try Ubuntu Linux LiveCD (boot from CD. Eliminates Windows as an error source)
 

TRENDING THREADS