Question Is my 6800xt broken? or am i just stupid? no leds when plugging it in.

JM_1__

Reputable
Jan 26, 2017
54
4
4,535
0
I have teh gigabyte oc 6800xt. it works fine been gaming for 3 days straight no crashes or hangs.. but im annoyed i can't see the led .. no led i switched the bios switch from silent to oc still no led. how do i get this led to turn on..

im using b550 tuf gaming mobo.. and isn't it supposed to be plug and play.
 

JM_1__

Reputable
Jan 26, 2017
54
4
4,535
0
i mean i have hte latest radeon software i installed it myself.
is it a hardware issue or software issue cuz the card is working fine.
 

okjak808

Reputable
Feb 23, 2018
193
26
4,640
7
https://www.gigabyte.com/MicroSite/512/rgb2.html

Try downloading this software and after that restart and run the software to see if the LED’s work. Even so they’re suppose to work even without the software installed.

If that doesn’t work try to DDU the card and reinstall the latest drivers for it, if that doesn’t work then it might be a hardware problem or maybe the model you have doesn’t have LED’s which it should have.
 

JM_1__

Reputable
Jan 26, 2017
54
4
4,535
0
i tried teh rgb 2 fusion stuff from ggabayte.. nothing no response from teh card its still black.

so what are the possibilities.. i got it new sealed. but no leds.. ? i mean the warranty stickers are still on so no one tampered with the cards. should i rma it?
 

madmatt30

Titan
Ambassador
The only thing that lights up in that card is the gigabyte logo on the side.

If that's all that's not working I personally wouldn't sweat it at all.

Not worth an rma, especially at the moment - you could be waiting months for a replacement card.
 
it is exactly like that
like that, or is that exact model number?
there's always a chance there is an updated version of that model and RGB could have only been added to the later revision(s).

all of the latest 6800 XT Gigabyte cards except the base version have some RGB options.
if you do in fact have the latest GAMING OC model, than you have an issue.

i would contact Gigabyte and troubleshoot the problem with them.
if they decide an RMA is the best option for you, you then need to decide if that little Gigabyte symbol not lighting up is worth possibly being without the card for who knows how long.
if they can guarantee a short return period, maybe go ahead.
 
Reactions: helper800
https://www.gigabyte.com/Graphics-Card/GV-R68XTGAMING-OC-16GD#kf


see it says u can adjust the gigabyte logo colors haha.. but mine is just off all the time off..
Yeah your card is deffective rma the card. Or send back to seller for replacement... However good luck getti g the seller to replace they dont follow the law 99% of the time when it comes to the keep a replacement for each card sold for deffect reasons... No no no that means they lose money forget that people never get broken cards in shipping sell them all.....
 

ASK THE COMMUNITY

TRENDING THREADS