Question Is my brand new 5800x CPU dead? works fine yesterady but today it suddenly dies, no POST, no beeps

zpendam

Distinguished
Oct 15, 2012
25
0
18,540
1
So I was replacing my 2600 with 5800x. Even bought new cooler for it too (Fuma 2). Everything is fine i can play games for hours, no issues at all. But then today i boot up my pc, a game suddenly crashed and system became unresponsive. I restarted my computer from start menu, and it wont turn on anymore. No POST, not even single beep. After i switch back to my old 2600 it works perfectly. Sso is my cpu suddenly dies itself with no reason?? There are no any visible damage on the processor, no signs of burnt processor or broken pin too. Im so confused
 
So I was replacing my 2600 with 5800x. Even bought new cooler for it too (Fuma 2). Everything is fine i can play games for hours, no issues at all. But then today i boot up my pc, a game suddenly crashed and system became unresponsive. I restarted my computer from start menu, and it wont turn on anymore. No POST, not even single beep. After i switch back to my old 2600 it works perfectly. Sso is my cpu suddenly dies itself with no reason?? There are no any visible damage on the processor, no signs of burnt processor or broken pin too. Im so confused
try this using your R5 2600(read till end):
  • Make sure ram is on slot 2 and 4
  • Disconnect from internet
  • Uninstall gpu driver DDU (clean and do not restart).
  • Uninstall all the processors (is a must, should be 12 on yours, also when it asks for restart, click on no and keep uninstalling all processors) on device manager like this:


    and the chipset driver/software in control panel (if there is none just skip)

  • restart the pc to bios, Flash Bios agesa 1.2.0.3, then after updating bios, replace the CPU.

  • After replacing CPU, go to bios again, then load default or optimized settings, find AMD SVM and IOMMU options, enable them (if the option is only auto and disable, just leave it auto), set your XMP/Manual OC and PBO/XFR back then save and exit.

  • boot up to windows and install the latest Chipset driver (should be 3.10.22), reboot, and then connect to internet.

  • Install the latest gpu driver.

    *do this all offline until reboot after installing chipset driver, also you may reboot to bios after all of this to set the XMP (and previous settings you did). Download needed files (highlighted word) before doing step 1, do the step by orders.

  • Run cmd as admin, then do chkdsk /x /f /r, after that do sfc /scannow

  • And check windows update (and optional updates) if there is any and install them (except chipset in optional update).

  • Make sure the psu connected to the gpu is 1 pcie cable per 1 slot (use main cable, not the branches/split) like this:
 

zpendam

Distinguished
Oct 15, 2012
25
0
18,540
1
which one i should try? i dont see any relevance uninstalling driver with my problem as its the windows part while my system wont be even able to POST or enter BIOS. I already on latest bios version too. Everything works totally fine yestereday.
 
which one i should try? i dont see any relevance uninstalling driver with my problem as its the windows part while my system wont be even able to POST or enter BIOS. I already on latest bios version too. Everything works totally fine yestereday.
With the 2600 installed check for any BIOS updates available. Get it installed. Also, update to the the latest chipset driver.

If the new 5800x doesn't work after that then it could have very well died.

What cooler did you have installed?
 
which one i should try? i dont see any relevance uninstalling driver with my problem as its the windows part while my system wont be even able to POST or enter BIOS. I already on latest bios version too. Everything works totally fine yestereday.
Try them all step by step in order while using the 2600. if it still cant boot after reflashing to bios agesa 1.2.0.3, then pretty much the cpu is dead. Usually this step i always use when replacing CPU within the same platform, more to "refreshing drivers/firmware" as this does works on experience.
 

zpendam

Distinguished
Oct 15, 2012
25
0
18,540
1
Have you checked CPU pins carefully from different angles and in good light? Are they perfectly aligned? Isn't there one pin that's standing different than others?
if that is the case then it wont work on the first place. like i said everything works fine yesterday, it just suddenly didnt work today
 

zpendam

Distinguished
Oct 15, 2012
25
0
18,540
1
With the 2600 installed check for any BIOS updates available. Get it installed. Also, update to the the latest chipset driver.

If the new 5800x doesn't work after that then it could have very well died.

What cooler did you have installed?

  1. I already installed newest bios
  2. The cooler i use is Fuma 2, temp is not the problem
  3. Everything works FINE literally yesterday and i can use my 5800x normally
  4. Today it dies for no reason
  5. No damages whatsoever, no burnt smell or anything, all parts, pins aligned correctly (If it isnt then how did it runs just fine yesterday)
 
Last edited:

zpendam

Distinguished
Oct 15, 2012
25
0
18,540
1
so RMA is the only way then. I already sent the claim couple of hours ago, still no reply. How long usually it take for the AMD support to reply the claim?
 
Mar 24, 2022
1
0
10
0
so RMA is the only way then. I already sent the claim couple of hours ago, still no reply. How long usually it take for the AMD support to reply the claim?
wow, exactly the same problem here. I just submitted RMA to AMD.. Some said on reddit that RMA with AMD takes 1 week if you're lucky.

My CPU also died in early March 2022 after a sudden crash (blank screen) and I swapped all other components except for the CPU to diagnose the problem. the symptoms are the same as yours: no POST, no display, and no beeps.

One guy said he heard 3 incidents of ryzen 5000 problems in this thread so this may be an AMD quality issue.... I'm a little disappointed because I never thought sudden CPU death was possible..
https://www.reddit.com/r/Amd/comments/lmk3bh View: https://www.reddit.com/r/Amd/comments/lmk3bh/my_5800x_died/
 

ASK THE COMMUNITY

TRENDING THREADS