Question Is my CPU at fault? RAM not running in dual-channel, 3rd board with RAM issues

Apr 26, 2020
8
0
10
0
i7-9700k
ROG STRIX z390-e Gaming Mobo
EVGA Superclocked 2x8 GB
RX750M Corsair PSU

To give some background, I'm on my third motherboard. I bought a z390 TaiChi Ultimate with the i7-9700k used from a seller. As soon as I got the board, I was having issues. I noticed in his picture he also was using the EVGA Superclocked RAM in single channel mode in only the B slots so he was obviously having issues at some point as well.

I ran Memtest, but it all came back fine.

I replaced the Motherboard with a used z390 Aorus ultra. When I went to boot up, it just displayed a DRAM LED on the board and codes (7F, C2, C4, C5, and 03). I couldn't get it to boot up to bios no matter how I configured the RAM. I also had a second set of the same RAM so I tried these sticks as well. Nothing worked. Without RAM it displayed the same error codes.

Yesterday, I decided to go to Microcenter and purchase a new Mobo to ensure that the used Mobos weren't the issue. At the time I thought they both were just faulty. I set up the new Mobo, but found that I had the same issue as with the original board. I can boot with 1 RAM stick and I can boot with 2 RAM sticks in single channel, but if I try dual channel it fails. Also, oddly enough, I can only put the ram in A channels now.

Now I'm thinking that maybe the CPU is causing this issue, but I don't have another lga 1151 to test my theory. I might buy a cheap one and test later. I really just wanted to get input from the community here.

Thanks for any feedback you can provide.
 

ASK THE COMMUNITY