Question Is my CPU dead?

TheNerdyGlaceon

Respectable
Oct 1, 2018
1,000
186
2,340
55
Bit of a long story.

A few months ago I built my first Ryzen build. I had a B550 Aorus Pro board with a Ryzen 9 3900X tamed by a NH-D15. Corsair Vengeance LPX 3200 CL16 RAM.

Recently, I upgraded the RAM to some 2x 16GB G.Skill Ripjaws V 3600 CL16 kit. And everything worked just fine. I was even able to increase the DRAM frequency to 3733 and pass several passes of Memtest86 without issues.

Problems started appearing immediately after I messed with the timings. Instead of leaving the default XMP timings (16-19-19-39) and DRAM frequency at 3733, I set about tightening the timings with the DRAM frequency still at 3733.

That went horribly wrong, my system rebooted several times until I managed to get into the BIOS, which was now freezing about 5 seconds in. Sometimes instantly. Instead of shutting the PC off from the PSU when this happened, I shut it off from the power button.

Then after several reboots, it wouldn't post at all and it was stuck on CPU.

Keep in mind I did not mess with any CPU settings in the bios. All on auto. All voltages, including SoC, on auto. DRAM voltage was 1.35v.

I then returned the board (and surprisingly got a refund), and now have a ROG Strix B550-F on the way.

The last thing I saw on that board was the CPU debug light being active, all fans at full blast. No CMOS resets, CMOS jumpers, anything, worked to reset the BIOS. DualBIOS didn't trigger. QFlash didn't work either. Thanks, Gigabyte.

So, my question is... Did I kill my CPU by messing with the RAM timings? I thought all that would happen if you got the timings wrong was either automatically reverting back to the working settings or no POST, which the latter can be fixed with a CMOS reset. But nothing worked in my case.

Is the CPU dead or did I just corrupt the BIOS?
 

JasonNs_

Great
Sep 22, 2020
161
14
95
0
Before you think that your CPU is dead, did you try to reset the BIOS ? and it could be the ram thats causing the problem not the CPU.
 

TheNerdyGlaceon

Respectable
Oct 1, 2018
1,000
186
2,340
55
Before you think that your CPU is dead, did you try to reset the BIOS ? and it could be the ram thats causing the problem not the CPU.
RAM is fine since I'm currently using it in my backup Intel build.

I couldn't reset from inside the BIOS since, as I said, it always froze either 5 seconds in or instantly. CMOS resets didn't work.
 

ASK THE COMMUNITY