Question Is my Ethernet port going on my MB?

gibsonstu

Distinguished
Apr 30, 2012
24
0
18,510
0
Hi all.
Lately ive been having an issue where my wired ethernet port will start flashing between no connection, identifying connection, and on. Ive changed nothing on my system so cant fathom why this is happening, and its not all the time, it can be fine all day then suddenly starts doing it. But now its becoming a daily occurrance and i need to do something about it. It only happens on my system, the wifes pc has connection while this is happening, as does the kids wifi.
Ive tried reinstalling ethernet drivers, motherboard drivers, changed router, swapped ethernet cords with my wifes pc. Still happening.

Is it my motherboard ethernet port on its way out? Its only 2 years old.

Thanks any advice is appreciated.

Motherboard
Gigabyte Technology Co. Ltd. H97M-D3H (SOCKET 0)
 
The easiest thing to do is to first swap cables at the router' end (between yours and wife' PCs). This will rule out that router port is bad. Next, check dofferent cable - if you can bring your PC to be pluggd into the cable your wife is using. And last - new PCI / PCI-express network adapter is like $15. Disable onboard LAN frmo BIOS if you go this way.
 

gibsonstu

Distinguished
Apr 30, 2012
24
0
18,510
0
The easiest thing to do is to first swap cables at the router' end (between yours and wife' PCs). This will rule out that router port is bad. Next, check dofferent cable - if you can bring your PC to be pluggd into the cable your wife is using. And last - new PCI / PCI-express network adapter is like $15. Disable onboard LAN frmo BIOS if you go this way.
Thanks for the reply. I already did try different cable and router port simply by switching the ethernet cable from my wifes pc into mine, and it still happened. I guess it must be the network adapter and will have to buy what you recommended. Is there a specific one you advise buying? or do they all perform the same? Thanks
 

ASK THE COMMUNITY

TRENDING THREADS