[SOLVED] Is my GPU dead? Crashed, then had artifacts on reboot, now can't even post, but can boot with iGPU

Nov 1, 2019
2
0
10
0
Specs:
6600k @ 4.5ghz
16gb RAM (one 2x4 kit, one 1x8 kit)
750W EVGA Nex B1
MSI Z170 SLI Plus
MSI 980ti LITE EDITION

I just downloaded destiny 2 and played maybe 10 minutes max when my computer completely shuts down, then when rebooting it shows artifacts and boots to this screen View: https://i.imgur.com/YjJWdmH.png


I immediately restart and from then on I cannot even get it to post. When I turn the computer on the GPU fans and lights work, but no output to the monitor, and my motherboard's VGA light is on.

I have tried repasting the gpu, trying different pci slots, swapping the PSU connectors.

However, I could boot normally into windows and use my computer normally if using the iGPU.

So does this mean my gpu is officially dead?
 

DSzymborski

Glorious
Moderator
Yes, it's very likely that this GPU has gone to heaven. The only question really is whether or not you bought the 980 Ti late enough that it's still covered by warranty. What you have above are the telltale sounds of the VRAM going, which is fatal.
 

DSzymborski

Glorious
Moderator
Yes, it's very likely that this GPU has gone to heaven. The only question really is whether or not you bought the 980 Ti late enough that it's still covered by warranty. What you have above are the telltale sounds of the VRAM going, which is fatal.
 
Nov 1, 2019
2
0
10
0
Well I actually received the 980ti as a prize in 2016 so I doubt I would've had warranty anyways.

Bought a used 770 as a stopgap until I build a new system next year.

It's just a shame because I never put it under much stress and kept thermals really well managed but also never used it to its full potential.

Did it being a "Lite Edition" have something to do with it dying so early in its life? I honestly expected it to stay with me for at least another 3 years
 

ASK THE COMMUNITY

TRENDING THREADS