Question Is my gpu dead?

seperoph

Distinguished
Oct 25, 2012
73
1
18,635
0
Tried turning on my pc today, GPU lights didnt turn on the fans on it were spinning at max speed.and no visual on either screen from the card.

I have reseated both ram,Checked cpu connection to board,Tried differnt slot for gpu,Unpluged everything. Tested two other gpu both of which work flawlessly but not the 3060ti.

OS:Windows 10
CPU: ryzen 5 5600
Motherboard: ASRock B550 Phantom Gaming 4
GPU: Rtx 3060 ti
PSU: Corsair CX 750
 

Lutfij

Titan
Moderator
How old is the PSU in the build listed above? As for the GPU's you've tried out, what are the makes and model of both GPU's tried in place of the RTX3060Ti? Try and drop the supposedly faulty GPU into a known working system with ample power from the PSU for the entire system.
 

seperoph

Distinguished
Oct 25, 2012
73
1
18,635
0
How old is the PSU in the build listed above? As for the GPU's you've tried out, what are the makes and model of both GPU's tried in place of the RTX3060Ti? Try and drop the supposedly faulty GPU into a known working system with ample power from the PSU for the entire system.
The PSU is most likely 5-6 years old. And the gpus tested are a EVGA GTX 1060 and a Gigabyte GTX 960
 

seperoph

Distinguished
Oct 25, 2012
73
1
18,635
0
I also recently within a week or so upgraded my MBO And CPU from a asrock ab350 pro4 and ryzen 5 1600 to the current list.
I also do not have another rig i can test it with unless i paid to have it tested at a local repair shop.
 

Lutfij

Titan
Moderator
I also do not have another rig i can test it with unless i paid to have it tested at a local repair shop.
No friend's or neighbors you know where you can drop your culprit GPU? You should also try and borrow a reliably built PSU to power your build. I wouldn't use a 5-6 year old PSU to power those parts.
 

seperoph

Distinguished
Oct 25, 2012
73
1
18,635
0
I also do not have another rig i can test it with unless i paid to have it tested at a local repair shop.
No friend's or neighbors you know where you can drop your culprit GPU? You should also try and borrow a reliably built PSU to power your build. I wouldn't use a 5-6 year old PSU to power those parts.
Yeah i don't live nearby anyone that would have a rig, Could the psu still be the issue even though it works with the 1060 and 960? I just find it weird that the fans run at max speed permanently when the 3060ti is plugged in. Also the gpu has worked for just shy of 3 months.
 

ASK THE COMMUNITY

TRENDING THREADS