Is my GPU dying? Game freezes and audio glitches

Slomka

Reputable
Sep 26, 2015
4
0
4,510
0
Is my GPU dying?

Status: UNRESOLVE

Computer Type: Desktop

GPU: GTX770 2GB Gigabyte

CPU: i7 6700k no overclock

Motherboard: ASRock Z170 Extreme 4

RAM: Corsair Vengeance 2x8GB

PSU: BeQuiet Dark Power Pro 750W

Operating System & Version: Win 10

GPU Drivers: 397.64 installed just after format

Description of Problem:

So. I've been having a few issues that i believe could be related. First of all when on my dekstop or any game. The screen would just go black for a second and turn back on. This happens on both screens \(2 monitors\), but just one at a time every 1\-2 hours.

Second issue. When in Destiny 2, the game would freeze for one second. Temperatures are fine around 70 degrees and the load is also around 70\-80%. What I noticed on the GPU usage chart is that when it happens the GPU usage suddenly drops. In one mission it happend a few time and after the freeze I lost the sound for 2\-3 seconds. Then everything got back to normal.

Third case. Warthunder often freezers completely after a few minutes of gameplay, but I'm still able to talk on TeamSpeak. The PC however needs a hard reset because it does not respond to anything.

And the fourth example would be PUBG in which when I open the inventory the game freezes for a second and then goes back to normal. When the freeze occurs you can see a decrese in GPU usage on the usage chart in MSI Afterburner.

What is more I noticed that when playing YouTube videos every couple of minutes I would get an audio glitch like white noise for a brief moment.

As you can see my GPU is quite old I've been using it happily for 5 years. Could it be just the end of its life? Or maybe this is some other hardware issue? CPU or MB?

Troubleshooting: I did clean Windows installation to eliminate all the possible software issues. Now I just have the drivers, a few game, teamspeak, diferent antivirus than before and some basic software like winrar, Opera etc.
 

Slomka

Reputable
Sep 26, 2015
4
0
4,510
0
You mean update the MB bios? I will do that once back at home :)

I have found one more solution. A guy had a similar problem and it was caused by audio drivers. Realtek interfering with Nvidia. I will try this fix as well.

And I borrowed a GPU from my friend so this will be the third check.
 

ASK THE COMMUNITY

TRENDING THREADS