Is my graphics card or motherboard broken? New PC help!

Jimmy Tryhard

Honorable
Mar 15, 2013
6
0
10,510
0
Hey everybody, I have just built my new custom gaming PC and have run into a couple of problems. At the first power on, everything worked except that I had nothing coming up on my monitor. All fans running, all lights on. I tried over and over with different monitors, no results. I unplugged my graphics card and tried using the integrated graphics, and it worked perfectly while using integrated graphics. But that is the problem. I can't play games on my CPU's integrated graphics! I have been doing that on my laptop, that's why I built a desktop!
So then I turned off my computer, re-plugged in my graphics card (Sapphire Radeon HD 7770 GHz Edition) and it had the same failure results as before. So I have come to the conclusion that either my graphics card is faulty or that my PCI Express 3.0 slot on my motherboard is screwed up. I am using the MSI B75MA-P45. I am going to get a free replacement of my graphics card to see if it works, but I would also need some advice from someone who is more experienced than I.

BTW: The fans on the graphics card work fine, the case I am using is the Cooler Master Elite 430 Mid Tower, motherboard: MSI B75MA-P45, and suspicious graphics card: Sapphire Radeon HD 7770. My working graphics is the intel hd ?000 on my i3 2120. I know a lot about intel hd, but I don't know yet for sure what I have on my i3 2120. My laptop runs HD 4000. My i3 most likely runs HD 2000.

ALL PARTS ORDERED FROM AMAZON.COM. When I get into the BIOS, all of my parts are detected, even all of my RAM. I can only get into the BIOS when my GPU is unplugged, however. I am using the integrated graphics on my i3-2120.
 

Jimmy Tryhard

Honorable
Mar 15, 2013
6
0
10,510
0


Thanks so much. I will post results as soon as my new card comes in. At least my hopes are up now.
 

SHIELDHEAD

Distinguished
Jul 6, 2009
120
0
18,690
2
It could honestly be either. Since you don't have 2 pci-e slots we can test one of the theories so I'd suggest that if you have another pci-e video card to try and plug that one in. Another issue could be that the card isn't receiving enough power but I'd doubt it. Also try BOTH dvi ports on the card(if your version has them)! Just return the card if nothing else works. and if that doesn't work return the motherboard.
 

makoau58

Distinguished
Aug 21, 2006
28
0
18,540
2
Go into bios and choose PCI Express for preferred graphics first instead of auto. It may be choosing your integrated Gpu by default. Anything is worth a try even though it should auto detect your GPU.
 

Jimmy Tryhard

Honorable
Mar 15, 2013
6
0
10,510
0
I just got my GPU replaced, SAME RESULTS! My card is all powered up and everything, I can see the fans spinning! BUT THE MONITOR WON'T SHOW ANYTHING!!!!! WHAT THE HECK!!!! It still works with the integrated graphics when I unplug the hd 7770!!!
 

Jimmy Tryhard

Honorable
Mar 15, 2013
6
0
10,510
0


I JUST GOT A NEW CARD! same hd 7770 but it STILL WONT WORK!
 

fbbam

Distinguished
Jun 6, 2011
105
0
18,690
2
what about your power supply cause that could be your problem
check all your connections once again
remove all other components i.e your drives, case lights if you have any just try it again with your board ram and processor.
then if your monitor has other connections try and use them with the card. Good luck
 

Jimmy Tryhard

Honorable
Mar 15, 2013
6
0
10,510
0
GUYS!!! I JUST FIXED IT!!!!!

Turns out I am an idiot and the monitor was plugged into the motherboard, not the graphics card!!! HOLY SWEET JESUS all that stress and hours of research for this...... gosh. This is my first time building a PC and next time I will definitely remember next time to plug in the monitor INTO THE RIGHT PLACE
 

fbbam

Distinguished
Jun 6, 2011
105
0
18,690
2


wow happy for you we learn by trying happy gaming!!!
 

ASK THE COMMUNITY