Question Is my monitor dying?

CptKevMan

Distinguished
Jun 3, 2010
34
0
18,530
0
ok so first off my specs :

msi b550 gaming carbon
Ryzen 7 3700x
g.skill tridentZ neo 32gb (2x16)
EVGA 3070 FTW3 Ultra
Corsair RMx 850w 80+ gold
Viotek gn32da monitor 1440p 144hz (primary monitor)
BenQ GW2765

I just recently got my hands on the 3070 at the end of January, thanks Newegg shuffle! And I've been having issues with my monitor crashing when games get minimized either by alt+tab or clicking in a different monitor. When the Viotek crashes I have to unplug it and plug it back into the power source to get it to do anything, I thought it was a faulty gpu at first so wrote EVGA explaining the issue and they told me to RMA, but I'm still having the same issue with the new card as well. It works fine if the game is in borderless windowed mode but some games don't have that option.

I'm at a loss as to what to do ... Anyone else have this issue? Or know how to fix it?

thanks!
Kevin
 
are you running in extended mode?
are both displays running at different refresh rates?
are both running through the same type of cables?
and do you have any type of cable extensions, port converter, or video out splitter or are both directly connected to the GPU via a single cable each?
 

CptKevMan

Distinguished
Jun 3, 2010
34
0
18,530
0
are you running in extended mode?
are both displays running at different refresh rates?
are both running through the same type of cables?
and do you have any type of cable extensions, port converter, or video out splitter or are both directly connected to the GPU via a single cable each?
Yeah, running in extended mode, the viotek is 144hz and benq is 60. using separate DP cables for both.
 

CptKevMan

Distinguished
Jun 3, 2010
34
0
18,530
0
when running only the 144Hz display with the 60Hz one turned off, do you still experience the issue?

many complain that certain monitors running simultaneously at different speeds cause odd issues within their OS.
Just disabled the 60hz, was able to alt+tab no problem but as soon as I quit the game the screen went black. Disabled the 144hz, ran the game on the 60hz and everything is fine. I've changed cables as well, still the same results.
 

ASK THE COMMUNITY

TRENDING THREADS