Question Is my Motherboard at fault for terrible wired/wireless internet speeds?

Oct 18, 2022
2
0
10
0
Recently acquired new system, however, the download speeds are 1/5 of what they normally should be. My other devices, my old system, and roommates devices all get around 200-300 Mbps download, (300Mbps ISP).
However with a fresh install (and even reinstall) of Windows, and even a dual boot with a fresh install of Ubuntu, my download speed stays consistently around 40-50 Mbps - no matter if I am using my PCie ASRock Wifi Card, or my onboard ethernet (Intel Ethernect Connection l219-v). I don't drop any packets and gaming on this new system has had no ping spikes, and no jitters on speed tests. (Speedtest Ookla and Fast.com)

Things I've Tried:

  • Resetting Router/Modem
  • Updating BIOS
  • Updating every driver on the motherboard's page, including testing both Windows 11/Asus Provided drivers
  • Buying new cat6 ethernet cables (Ethernet port is flashing orange)
  • Reconfiguring NIC properties in Device Manager (Link Speeds, ethernet energy settings... etc)
  • Updating OS
  • Removing my wifi card and only using ethernet
  • Switching ports on the router
  • Updating router firmware
  • Resetting Winsock / Flushing DNS / release and reset IPConfig / nbtstat -rr
  • Booted Ubuntu on my hard drive and testing speeds there
System Specs
  • ASUS Prime z590-v Motherboard
  • RTX 3080
  • I7-11700kf
  • 32GB 3200Mhz Tforce Ram
  • 1TB WDC SSD, 1TB Toshiba HDD
  • Windows 11 - Home 64
  • Ethernet Nic - Intel(R) Ethernet Connection l219-V Driver Version 12.19.1.37
  • AsRock 802.11 Dual Band/Bluetooth Wifi Adapter
I was assuming my motherboard was faulty but everything else works and I don't ever disconnect from either wifi or ethernet, but booting on Ubuntu also shows that it isn't a windows issue.
Am I missing anything?
 
Does the ubuntu run as a virtual machine or did you dual boot the machine. I commonly recommend people boot linux to test stuff like this but most times just from a USB stick to avoid damage to the windows install.

If 2 different OS do the same thing it is more likely a hardware issue but when both wifi and ethernet are affected I couldn't say what it is. Strange errors with say memory or cpu clock rates would not have much impact on network without affect lots of other stuff.

So maybe try the more standard things. Try to disable IPv6 in the nic settings. Asus likes to load "gamer" network stuff in the bloatware they ship with motherboards. Try to uninstall whatever they are calling it now days. Used to be called lanfirst but now I think they actually just use CFOSspeed. In any case uninstall any software that claims to favor one kind of traffic or do any kind of QoS.

The IPv6 thing might apply to both OS but the bloatware does not get installed into linux systems.
 
Oct 18, 2022
2
0
10
0
No sign of CFOSspeed, and yes I did boot with a USB drive. Disabling IPV6 does not do anything either. I tried disabling Windows Autotuning but that also did not help.
 

ASK THE COMMUNITY

TRENDING THREADS