Question Is my Motherboard the issue when attemping to Crossfire

Feb 27, 2019
6
0
10
0
Hello everyone. while attempting to play Apex Legends, my game kept freezing on my old system (i3 4130 and AMD R9 270x), so I decided to upgrade some components, primarily Crossfiring my GPUs. I couldn't find another R9 270x so I switched to dual R9 280x.

The problem now is that I can't seem to get Crossfire to work. The first problem is that I can't find the crossfire option in Catalyst Control Center and secondly, my second PCI-e slot is only running at x2 speed. I've tried running one card at a time in each of PCI-e slots #1 and get 16x speed, however, when I use the 2nd PCI-e slot I only get 2x speed even if only using 1 card. Even when taking out the wireless network adapter I only get 2x speed on the 2nd PCI-e slot in both single and dual GPU configurations.

I've updated to the latest GPU drivers and attached a picture of my BIOS version (Having trouble uploading the image, but the BIOS version is American Megatrends Inc. 0311, 2013-04-18 and my GPU driver version is 25.20.15021.1007) . There's a more recent BIOS version, but it keeps failing when I attempt to update it.

After doing some significant research on my own, I think my problem is limitations on my motherboard. Specifications state that is it crossfire ready, but that the second PCI-e slot will be restricted to 4x speed (I'm only getting 2x speed though). Any recommendations or confirmation on this fact would be greatly appreciated.

Here's my setup now:

CPU: Intel - Core i5 4670k
CPU Cooler: Cooler Master - Hyper 212 LED
Motherboard: Asus - Z87M Plus
Memory: G.Skill - Ripjaws X Series 4 x 4 GB
Storage: Crucial - M500 240GB
Storage: Western Digital - Blue 1 TB
GPU: Gigabyte - Radeon R9 280X 3GB
GPU: Gigabyte - Radeon R9 280X 3GB
PSU: Seasonic - Focus Plus Gold 850W
Case: Bitfenix - Shinobi Window ATX Mid
OS: Windows 10 Pro 64 bit
Wireless Network Adapter: Asus - PCE-N15 PCI-express x1
Case Fans: Cooler Master SickleFlow 120mm (x2)
 
Last edited:
Feb 27, 2019
6
0
10
0
assuming you have the cards connected with the crossfire cable
look here;
How to Configure Discrete Graphics Cards to Run In AMD CrossFire™ Mode
https://www.amd.com/en/support/kb/faq/dh-018
Yes, the cards are connected via crossfire cable. I have read the FAQ and it looks like I need:

The motherboard must be AMD CrossFire™ certified with at least two PCIe x16 slots available, running at a minimum of PCIe x8 speed. Please check with the motherboard manufacturer for AMD CrossFire compatibility.

According to my Motherboard specs:
Multi-GPU SupportSupports AMD Quad-GPU CrossFireX™ Technology
  • Expansion Slots
    1 x PCIe 3.0/2.0 x16 (x16 mode, yellow)
    1 x PCIe 2.0 x16 (x4 mode, dark brown) *1
    2 x PCIe 2.0 x1
I'm fairly sure that it's my mobo limiting the speed of the second PCI-e slot.
 

Rogue Leader

Titan
Moderator
I'm fairly sure that it's my mobo limiting the speed of the second PCI-e slot.
And you would be correct


you have a PCIe wireless adapter in x1 slot 2 see note *1 on that page:

The PCIe x16_2 slot shares bandwidth with PCIe x1_2 slot. The default setting is x2 mode. Go to the BIOS setup to change the settings.
You need to yank that wireless card and then it will work.

PS Crossfire is pretty awful in general, and even more awful at 16x/4x. You are better off selling those cards and getting an RX 480 or RX 580, it will be slower but the performance will be "better" (as in smooth, supported by everything, and not glitchy). I did the same thing on my old setup after I got tired of the crap involved with Crossfire.
 
Feb 27, 2019
6
0
10
0
And you would be correct


you have a PCIe wireless adapter in x1 slot 2 see note *1 on that page:



You need to yank that wireless card and then it will work.

PS Crossfire is pretty awful in general, and even more awful at 16x/4x. You are better off selling those cards and getting an RX 480 or RX 580, it will be slower but the performance will be "better" (as in smooth, supported by everything, and not glitchy). I did the same thing on my old setup after I got tired of the crap involved with Crossfire.
I have since been running my PC without the wireless adapter since I am hardwired to my network. Even then, I don't see an Crossfire option in Radeon settings.
 
Feb 27, 2019
6
0
10
0
The card is physically removed? and there are no other cards in any other slots only the 2 GPUs in the 2 x16 slots?
The wireless network card is physically removed. Only the 2 GPUs are installed in the 2 x16 slots, but I'm guessing due to the limitations of the board, I'm only getting x16 on the primary GPU and x2 on the secondary GPU. Even then, it's not showing up in Crossfire in Radeon settings.
 

mgallo848

Commendable
Apr 4, 2018
1,551
34
1,790
132
A few years ago I crossfired my HD 7970's (Basically the same as your 280x's)

My crossfire would not work unless I used 2 crossfire bridges. If I removed one of the bridges it would actually give me a "pop-up" telling me I need 2 bridges to enable it.

FYI: Your MB is listed as crossfire compatable

Rogue is correct, You would be much better off selling the 2 cards and get 1 fast card instead. The gameplay is much smoother with less graphic glitches.
 
Reactions: xamus21

Rogue Leader

Titan
Moderator
The wireless network card is physically removed. Only the 2 GPUs are installed in the 2 x16 slots, but I'm guessing due to the limitations of the board, I'm only getting x16 on the primary GPU and x2 on the secondary GPU. Even then, it's not showing up in Crossfire in Radeon settings.
That second slot should run at x4 with all other PCIe slots empty. The second one only runs x2 when the other slot is populated.

I'd go into the BIOS and make sure the slot is being recognized as x4, maybe some setting is residual from when you had the Wifi card in there.
 
Feb 27, 2019
6
0
10
0
I tried installing both crossfire bridges, but still not recognized in Radeon settings.

My version of BIOS only has 3 settings for PCI-e: Auto, Gen 1, Gen 2. I've tried all settings to no avail. Also have tried updating my BIOS according to this guide. However, the update is not successfully installing.

At this point, I am thinking of scrapping the Crossfire attempt and getting a single RX 570 or 580 (both 8gb versions). Is a $50 price difference worth the extra cost for the 580 in your opinion?
 

Rogue Leader

Titan
Moderator
I tried installing both crossfire bridges, but still not recognized in Radeon settings.

My version of BIOS only has 3 settings for PCI-e: Auto, Gen 1, Gen 2. I've tried all settings to no avail. Also have tried updating my BIOS according to this guide. However, the update is not successfully installing.

At this point, I am thinking of scrapping the Crossfire attempt and getting a single RX 570 or 580 (both 8gb versions). Is a $50 price difference worth the extra cost for the 580 in your opinion?
You will be MUCH happier with a Single RX 580, yes its worth the $50.

before the system I have now I went from 2 R9 280 in Crossfire to 1 RX 480 I got on launch day. I lost about 1000 points in 3d mark, but EVERYTHING played better, smoother, no compatibility issues. Its a way better choice.
 

mgallo848

Commendable
Apr 4, 2018
1,551
34
1,790
132
Just in pure benchmark numbers, the RX580 8gb is slightly faster than the 280's in crossfire.

Back when I stopped running my 7970's in x-fire I bought an R9 390x and it performed the same in the games I played (but much smoother frametime)

The RX580 is even a little faster than the 390x
 
Reactions: Rogue Leader
From manual:
"The PCIe x16_2 slot shares bandwidth with PCIe x1_2 slot. The default setting is x2 mode. Go to the BIOS setup to change the settings. "
That explains why you see x2 mode even without any other PCIe devices installed.
The option you are looking for is in BIOS at the following path: Advanced Menu>Onboard Devices Configuration >PCI Express x16_2 slot (dark brown) bandwidth. Set it to x4 and try again.
 
Feb 27, 2019
6
0
10
0
From manual:
"The PCIe x16_2 slot shares bandwidth with PCIe x1_2 slot. The default setting is x2 mode. Go to the BIOS setup to change the settings. "
That explains why you see x2 mode even without any other PCIe devices installed.
The option you are looking for is in BIOS at the following path: Advanced Menu>Onboard Devices Configuration >PCI Express x16_2 slot (dark brown) bandwidth. Set it to x4 and try again.
Thanks for listing the pathway to change the settings in BIOS. With that changed, the 2nd GPU is running at 4x speed (max as listed in my mobo specs) and I have enabled Crossfire successfully.

I'll try searching up some benchmarks and test some actual gameplay since most published articles assume that Crossfire is enabled in a x8/x8 or x16/x8 configuration.
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS