[SOLVED] Is my PC dying? Nasty screen of death inside

Phazoner

Honorable
I was on Halo Reach's beta campaign and after a few minutes, when I was just about to engage in the first fight the whole PC freezed, sound was like a machinegun stuck and repeating, which can happen, but ultimately a terrible noise started going out of my speakers which somehow I identify like a electric output. Pressed the panic button, shut down the PC and trying to restart I got this:



I have had to restart it like 20-30 times plugging and unplugging and stuff until it finally came back to life but after 10 tries I really thought it was dead. I think I've never ever had before such a freeze and don't know if it can be related to Reach.My specs are:

MSI unknown MoBo (prebuilt Nightblade X2B B150 chipset)
i7 6700k
GTX 1070
Playing on 4K, improved graphics, default FOV.
 

Dunlop0078

Champion
Herald
You might want to check event viewer and see if it logged anything when the issue occurred. that could point you in the right direction, I suspect you may see some kind of directx error that would point towards the GPU of GPU driver.
 

Dunlop0078

Champion
Herald
Hmm thats odd. I would assume its some kind of graphics issue either there is a hardware problem with the GPU, possibly a power issue with the PSU, or the driver crashed and burned bad. I would do a clean reinstall of the GPU drivers with DDU and hope that solves it. If it occurs again then you may be looking at some kind of hardware issue.
 

Dunlop0078

Champion
Herald
You might want to check event viewer and see if it logged anything when the issue occurred. that could point you in the right direction, I suspect you may see some kind of directx error that would point towards the GPU of GPU driver.
 

Phazoner

Honorable
You might want to check event viewer and see if it logged anything when the issue occurred. that could point you in the right direction, I suspect you may see some kind of directx error that would point towards the GPU of GPU driver.
There are some Warnings from DistributedCOM three minutes before two final warnings where it said Disk 8 was enexpectedly disconnected and less than a minute later Disk 6. It's weird because some partition software I have shows 5 drives connected, 6 counting a microSD that I had plugged at that time.

I have cleaned with DDU, installed latest drivers and used Unigine in 1080p, 4K and 8K modes for about half and hour and it was fine, really weird. Looks like both graphics and PSU are OK, maybe a driver related issue.
 

ASK THE COMMUNITY

TRENDING THREADS