Question Is the problem I am having related to my new Ram kit or the motherboard or/and CPU?

myaccount1234

Honorable
Sep 12, 2015
96
1
10,645
1
Quick info facts.

1. CPU AMD Ryzen 2700 overclocked to 4.00 GHz with auto settings with be quiet! 250W TDP Dark Rock Pro 4

2. Motherboard model is- MSI X370 GAMING PRO CARBON

3. Ram- CORSAIR VENGEANCE® LPX 16GB (2 x 8GB) DDR4 DRAM 3200MHz C16 Memory Kit. CMK16GX4M2D3200C16 Both the old and new kit. Ram speed XMP Profile 3200MHz 16-19-19-36

I first will start with background info before getting into the problem. I recently bought 2 new ram sticks so that I would have 4 sticks and a total of 32gb ram. I done my research and found the exact same ram to match with the old ram. The old ram model is called CMK16GX4M2D3200C16. The new ram model is also the exact match CMK16GX4M2D3200C16. I looked at the SPD info of both ram kits; they are both Samsung B-die and same speed, timings. So, I can conclude the new ram works with my motherboard. I will now explain the problem I am having. The day I installed the ram I did system stability test with the software called OCCT. I did the ram test, the Test failed. I also noticed the system seemed a bit off too. I loaded Beam.NG Drive and loaded up traffic. The game crashed a minute later. My CPU was overclocked to 4.00 GHz, so I restored to default settings, but kept the Ram’s XMP profile. The ran the test ran failed again. I also ran a Cinebench R20 benchmark it passed with errors. To remove any reasons of the Ram needs RMAed I ran the software memtest64 non + on USB. I first ran the test with only the old ram kit. The test passed with no errors. I then ran the test again with the new ram kit. The test passed with no errors. I also experienced no problems with the new ram with windows running only at 16gb. I was bit confused over this. I decided to run the test again with all 32gb ram, it passed with no errors. I then found out the ram speed was not running at 3200MHz 16-19-19-36 with the test. I then ran the test again with 3200MHz 16-19-19-36m, it failed with 32gb ram. I was about RMA the new Ram kit, until I found the software memtest64+. I then tried to run the memtest64+ off USB it was keeping not booting. So used the Linux distro, Fedora-Workstation. I learned online the live USB iso had the memtest64+ test build in it. I first ran the test with new kit first, it failed as expected. To avoid if the problem is the motherboard, I ran the test again but this time with the old kit. The test failed with the old ram. Now here is the question I am asking, both tests failed at test 07. The new ram kit failed with test 07 and CPU 5. The old ram kit failed with test 07 and CPU 03. If the problem was the new ram kit, why would the old ram fail too? This made me think back, of problems that I had that might been ram related. I noticed Beam.NG Drive crashed a few times to black screen a few times after playing about 20 minutes. I thought this was just the game. I do know this game uses more system ram then most games.

Questions I have about this problem.

1. Is this a motherboard problem?

2. Is this the new ram problem and I need to RMAed?

3. Why did the old ram fail memtest64+ also?

4. Why both old and new ram kits pass the memtest64 non +.

5. Why when I run all 4 sticks at 32gb, both memtest64 non + and memtest64+ fail.

6. Is it possible my CPU damaged, from overclocking?

7. Only both tests fail at test 07, but old ram failed with CPU 03 and new Ram with CPU 05

8. What should I do?
 
This comes down to a RAM mismatch. You should NOT mix RAM kits even if they have the same specs.
Yes I know they sometimes do work however yours do not. You can try manually configuring in Bios with no guarantee.

There can be minor differences in Density/Latency and that's why DIMMs are binned at the factory. Manufacturers warn of this.

Best is to get a single kit (2x16) at a frequency that the MB and CPU support and chosen from the MB QVL.
That way you know they have been tested and known to work.
Return the new kit and keep the others as spares.
 

ASK THE COMMUNITY

TRENDING THREADS