Is this a HDD problem, or something else?

DRosencraft

Distinguished
Aug 26, 2011
743
0
19,010
I built my PC about a year ago with a WD Caviar Green 750GB drive. Back in September, it began reporting a SMART failure, so I replaced it with a 1TB Seagate (before the prices hit the roof). Just over 30 days later, the Seagate suddenly stops working. It made some kind of slow clicking noise like a baseball card in the spokes of a very slow bike. At the time I chalked this all up to a streak of a little bad luck and got Seagate to send me a new drive. But now, last week my drive suddenly made this god-awful loud, high pitched, shrieking noise for about a minute. I tried to check everything out and it seemed okay. Connections were good, the PC was still working, and Windows wasn't reporting any problems. Now today, while I was using it, the computer suddenly restarted and said there's no boot drive. I pull the drive, stick in my borther's computer, and sure enough it's not reading the drive. Here's my question; Is this just really bad luck with HDDs to have 3 go bad in less than four months, or is it probably something else? I'm thinking it's possible that it may be a motherboard problem since I know I also have a non-functioning memory slot. I've also considered that it may be a problem with the PSU, but I have yet to notice any other problems that would indicate a power supply problem.

My system at the moment is as follows:
Biostar TA890FXE motherboard, AMD 1090T CPU, Rocketfish 1000W power supply, Radeon HD 6950 GPU, 1TB Seagate Barracuda (the bad drive), Windows 7 ultimate
 
Solution
I would say possibly bad PSU or Motherboard (to be more precise bad chip set), I can't believe you just got 3 bad drives in row, something in your PC make them go dead overtime.
thou PSU can seem good it can spike one of the voltages once a month for example.
Bad sata chipset can make you cry working one day frying HD the next

such problem is very hard to diagnose, i seen customers who fried like 5 HD's cursing manufacturer,

DRosencraft

Distinguished
Aug 26, 2011
743
0
19,010


That's what I thought. I was a bit worried I guess that there might be a Vreg or NorthBridge problem ocassionally spiking power on the drive or something like that. I really don't want to be RMAing and replacing HDDs every few months like this.
 
What you should check first is that you are getting air flow over your hard drives. If the front intake vents are blocked by dust or by a carpet then you may not be getting enough air flowing over the hard drives which could result in their failure. Heat kills hard drives, I have never known a power supply to do so.
 

duxducis

Distinguished
Sep 24, 2007
489
0
18,860
I would say possibly bad PSU or Motherboard (to be more precise bad chip set), I can't believe you just got 3 bad drives in row, something in your PC make them go dead overtime.
thou PSU can seem good it can spike one of the voltages once a month for example.
Bad sata chipset can make you cry working one day frying HD the next

such problem is very hard to diagnose, i seen customers who fried like 5 HD's cursing manufacturer,
 
Solution

DRosencraft

Distinguished
Aug 26, 2011
743
0
19,010


The front intake is perfectly clean. I did a thorough cleaning when I replaced the WD and again when I replaced the last Seagate. From memory the peak temps reported by the HDD were around 32C, and idle was only a few degrees south of that, ~28.
 

DRosencraft

Distinguished
Aug 26, 2011
743
0
19,010
This problem really is a pain to diagnose. There isn't really a good way to b e sure you catch the problem, and as I've said, having to replace a HDD every few months is ridiculous. In a perfect world I would replace my MB and PSU right now. But I wanted to wait on the MB because I have the 890fx chipset and wanted to jump to the 1090fx chipset which should be out soon, relatively speaking.

While I don't deny I could just have really crappy luck and ran into a streak of bad drives, I do have to recognize that I could be have a bad MB or PSU occassionally spiking volts on the HDD and causing problems. As one migh expect, Seagate has said the same thing; there isn't sufficient airflow over the drive or that there ould be a power surge of some sort.

So, here's what I've decided. I'll be doing an RMA on this drive and trying my luck one last time. If things don't pan-out, I guess I'll be skipping the 1090fx generation and going with the 1190fx chipset in the next couple years. I'll look to replace my PSU sooner, in the next few weeks if my personal finances allow it. So, thank you to everyone who replied, I appreciate your thoughts. Good luck with your own systems and projects. :hello:
 

TRENDING THREADS