Is this a sign of a bad/damaged hard drive?

gumbob3

Respectable
Mar 5, 2016
410
0
1,810
20
My friend's computer, although slow, used to work perfectly fine. Now, when he turns it on it will get stuck loading windows. We can leave it running for 10+ minutes, and it won't even make it to the windows login page (where you can choose a user/account). I tried to get into the BIOS, but the computer doesn't recognize the keyboard or mouse. Could this be a bad/damaged hard drive? Thanks!!
 

3ogdy

Distinguished
Jul 13, 2009
726
5
19,165
77
Since you can't enter BIOS, try opening the computer up. Disconnect the power cable from the power supply before you do so. After removing the power cable, press the power button on the computer to drain whatever electric current there was in the PSU.
Once you've opened the computer case, remove the battery from the motherboard. Leave the system without the battery for at least 5 minutes, then try turning it on without the battery and see if you can get to the BIOS using your peripherals.
If no image shows on the screen, turn the systme off, connect the battery and start your PC again. If the peripherals still don't work (I assume you're using USB keyboard and mouse) try connecting a memory stick or an external HDD and see if you get any power to the USB ports in the first place.)

Usually, you should be able to use the KB and mouse even if the GPU / CPU / RAM is bad to some extent. I dont' know how clean the computer is on the inside, but dust can cause trouble so reseating RAM and GPU with the PC turned off then retrying is an option.
Also, see if the systme works fine without any HDD / optical drive connected to the motherboard. Another thing worth trying is booting the computer with the least amount of hardware connected to it (the bare minimum should be: motherboard, CPU, 1 RAM stick - if you have an integrated GPU, use that one and remove the dedicated one, if you don't have an iGPU then keep the one currently inside the case, no optical disk drive (neither DVD-RW nor HDDs/SSDs), no other device connected to the system internally / externally except the keyboard and the screen. If the system DOES work that way, your problem is most likely the Power Supply Unit.

If that still doesn't work, I'm afraid you might have a failing southbridge on the motherboard or the USB controllers are dead. That implies you need to get a new mobo. If you do manage to make it work and get past the BIOS though but can't boot into Windows, make sure the BIOS is configured correctly (check whether IDE mode or AHCI is selected under the chipset section in the BIOS. Try booting with both.)

If the system still doesn't boot with the default BIOS settings or with the AHCI /IDE setting changed.
After the system gets after the BIOS screen, can you use your keyboard? Before you see the Windows laoding screen try hitting F8 repeatedly and try booting into Safe Mode. See if that works. If it doesn't the culprit is most likely the motherboard.
If you can get into Safe Mode, the system might have a failing Windows installation or HDD. Get HDD Regenerator , boot from its image and run a scan with the fix option and see if it finds any bad sectors on your HDD. Also, make sure you try more than just one SATA port on your motherboard - especially if the ports available have different colors.
 

CBender

Reputable
Dec 30, 2015
1,018
1
5,960
213
If the computer doesn't recognize the keyboard/mouse your problem is not the hdd. Something feels wrong about the mobo. If you can find a ps/2 keyboard or try every available usb port to see if the keyboard works. And we go from there.
 

gumbob3

Respectable
Mar 5, 2016
410
0
1,810
20


We tried (i think 2) PS/2 keyboard, still nothing :/
 

gumbob3

Respectable
Mar 5, 2016
410
0
1,810
20


We tried a few PS/2 keyboards, and a few USB keyboards. The computer is quite old, so no USB 3.0.
 

CBender

Reputable
Dec 30, 2015
1,018
1
5,960
213
Start by resetting the bios. Remove the cmos battery for a good couple of minutes, if you haven't already. Also try removing the memory and turning it on. It might shock the system enough to start working a bit better.

Although I have to say that if it is an old system I wouldn't get my hopes up.
 

gumbob3

Respectable
Mar 5, 2016
410
0
1,810
20


Will anything happen if the CMOS battery is dead? The computer is probably older than 6 years old. I looked it up, and the CMOS battery would be dead by now. Could it do any good or harm? Thanks!!
 

3ogdy

Distinguished
Jul 13, 2009
726
5
19,165
77
Since you can't enter BIOS, try opening the computer up. Disconnect the power cable from the power supply before you do so. After removing the power cable, press the power button on the computer to drain whatever electric current there was in the PSU.
Once you've opened the computer case, remove the battery from the motherboard. Leave the system without the battery for at least 5 minutes, then try turning it on without the battery and see if you can get to the BIOS using your peripherals.
If no image shows on the screen, turn the systme off, connect the battery and start your PC again. If the peripherals still don't work (I assume you're using USB keyboard and mouse) try connecting a memory stick or an external HDD and see if you get any power to the USB ports in the first place.)

Usually, you should be able to use the KB and mouse even if the GPU / CPU / RAM is bad to some extent. I dont' know how clean the computer is on the inside, but dust can cause trouble so reseating RAM and GPU with the PC turned off then retrying is an option.
Also, see if the systme works fine without any HDD / optical drive connected to the motherboard. Another thing worth trying is booting the computer with the least amount of hardware connected to it (the bare minimum should be: motherboard, CPU, 1 RAM stick - if you have an integrated GPU, use that one and remove the dedicated one, if you don't have an iGPU then keep the one currently inside the case, no optical disk drive (neither DVD-RW nor HDDs/SSDs), no other device connected to the system internally / externally except the keyboard and the screen. If the system DOES work that way, your problem is most likely the Power Supply Unit.

If that still doesn't work, I'm afraid you might have a failing southbridge on the motherboard or the USB controllers are dead. That implies you need to get a new mobo. If you do manage to make it work and get past the BIOS though but can't boot into Windows, make sure the BIOS is configured correctly (check whether IDE mode or AHCI is selected under the chipset section in the BIOS. Try booting with both.)

If the system still doesn't boot with the default BIOS settings or with the AHCI /IDE setting changed.
After the system gets after the BIOS screen, can you use your keyboard? Before you see the Windows laoding screen try hitting F8 repeatedly and try booting into Safe Mode. See if that works. If it doesn't the culprit is most likely the motherboard.
If you can get into Safe Mode, the system might have a failing Windows installation or HDD. Get HDD Regenerator , boot from its image and run a scan with the fix option and see if it finds any bad sectors on your HDD. Also, make sure you try more than just one SATA port on your motherboard - especially if the ports available have different colors.
 

ASK THE COMMUNITY