*Issue* Preferred GPU keeps changing to Integrated

Aug 3, 2018
3
0
20
1
I currently have a Lenovo ThinkPad E570 with some kind of hybrid GPU that consists of an Intel HD 620 Adapter and a Nvidia Geforce GTX 950 (You'll have to excuse me whenever I incorrectly state something, I'm new here and I still don't quite understand how computers work.) Lately I've been noticing when running 3D games that my game runs poorly and only uses the integrated graphics. I've been using Geforce overlay and MSI afterburner and both state that the GTX 950 is not in use.

Here are a list of things that are happening:

- When I open the Nvidia control panel, in the 3D settings tab the preferred graphics processor box is grayed out, seeming to be locked on the Integrated Graphics option
- I cannot open my Intel Graphics Control Panel, it will show the initializing overlay when I click on it from the desktop, but after that it disappears and it doesn't open.
- If I reset the settings to default, select the GTX 950 and click apply, the box grays out again and shows the Integrated graphics option

Downloading and reinstalling the Nvidia driver from the website seems to temporarily bring things back to normal (I can open the Intel control panel and use my gpu to play games) but after a while the same issue happens again.

Does anyone know how to fix this? Sorry if reading this gave you a headache, I'm new here.
 
Aug 3, 2018
3
0
20
1
It ended up being a Lenovo power management driver issue, I installed the new one and everything was fine. I believe the old driver kept setting my laptop to "power saving" settings, forcing all the apps to use the power saving gpu, the integrated one.
 

Lutfij

Titan
Moderator
1| What OS are you working with?
2| Are you on the latest BIOS update for your laptop/motherboard?
3| In Device manager, see if there are any yellow exclamation marks flagged against the (discrete)GPU.
 
Aug 3, 2018
3
0
20
1


While checking for the things you mentioned I noticed there were many driver updates that I was not aware of, I'll look into those and see if they solve the problem and I'll reply back, thanks!

So I updated the drivers, and games still refuse to work on the GPU.
1. I am on Windows 10
2. I believe that my BIOS is the latest
3. The device manager shows that the display adapters are all working properly
 
Aug 3, 2018
3
0
20
1
It ended up being a Lenovo power management driver issue, I installed the new one and everything was fine. I believe the old driver kept setting my laptop to "power saving" settings, forcing all the apps to use the power saving gpu, the integrated one.
 

ASK THE COMMUNITY

TRENDING THREADS