Question Issue RAM Dual Channel: Corsair Vengeance 32Go

Aug 25, 2019
3
0
10
0
Hello all,

I am very new to the PC building game, I just assembled my first one last week.
I am having an issue with the RAM that I did not manage to solve myself. I am coming here to ask for help :)

The first time I tried to boot the PC with two sticks of RAM in the suggested slots for dual channel (number 2 and 4), I had no signal on the screen. Black screen. On the mother board, the "EZ debug" lights for "CPU" and "DRAM" were blinking alternatively.
I removed both RAM sticks and put only one back. No matter where I put it (slot 1, 2, 3 or 4), the computer starts normally. I tried with the other RAM stick (only one stick at a time). It works just fine. I concluded that RAM sticks are both ok (when I use them individually) and all the RAM slots are fine.
If I put the 2 RAM sticks in non-dual channel (at the moment in slots 1 and 2), the computer starts just fine (except for a warning message telling me that the sticks should be in 2 and 4 !). 32Go are detected.
If I put the 2 RAM sticks back in dual channel (slots 2 and 4), I go back to the Black Screen.

Here is my config:
Mobo: Msi MPG Z390 Gaming Pro Carbon AC
CPU: Intel Core i9 9900KF
Colling: Corsair Hydro 100i
RAM: Corsair Vengeance 32Go (2x16Go), DDR4
GPU: GeForce RTX 2080 Gaming Trio
SATA: Seagate 4 TB BarraCuda
SSD (not installed yet – shipping problem) Samsung SSD Interne 970 EVO Plus NVMe M.2
PSU Corsair RM850x
Box: Corsair Crystal 570X

I have update the MOBO bios, it did not solve the issue.
Would anyone have suggestions?
Thank you in advance :)
David
 

Lutfij

Titan
Moderator
Which version of the BIOS are you currently on? You may want to manually reflash the BIOS with the latest off of MSI's support site, using a FAT32 formatted pen drive. Keep in mind to have the single stick of ram on your board on the slot you'd normally use for dual channel setup, i.e DIMM A2.
 
Aug 25, 2019
3
0
10
0
Thank you for your answer.
The version of the BIOS is E7B17IMS.150 (latest one according to MSI).
I did another round of checks. It seems one single stick works in DIMMA1 or DIMMA2. It does not start with one stick in DIMMB1 or DIMMB2. Both sticks work together in DIMMA1 and DIMMA2.

So it seems the issue is with DIMMB1 or DIMMB2. But I have no idea what it is.
 
Aug 25, 2019
3
0
10
0
I have contacted MSI support who suggested a clean BIOS (I did) and an update of the BIOS (I did).
I still cannot use DIMMB1 or DIMMB2. My RAM (Corsair Vengeance 32Go (2x16Go), DDR4) has to be in DIMMA1 or DIMMA2 or both together. Therefore, I cannot follow the recommandation to use DIMMA2 and DIMMB2...

I do not know what to do next.
 

ASK THE COMMUNITY

TRENDING THREADS