Question Issue with AMD graphics driver installation

Jul 27, 2020
1
0
10
0
I recently built my PC and it worked perfectly fine for about a week and then one day it refused to boot. The motherboard loading circle would freeze and my PC would restart. I tried everything to get it to boot but couldn't get it to boot outside of safe mode. I finally gave up and wiped my SSD and reinstalled windows then everything seemed to work fine until I went to install AMD graphics drivers.

Whenever I go to install them they crash my PC right as it finishes installing and I get the same booting issue. I figured out I could get in on safe mode and delete the drivers to log back in normally. I tried everything I could think of to fix it and I don't understand what the problem is since the first time I set up my PC I didn't have any issues.

I tried installing the drivers manually, in safe mode, and resetting CMOS, updating BIOS, and doing a clean install of my graphics drivers, but it still crashes right as it's about to install. I'm 100% sure I have the right drivers since I installed it exactly the same way I did the first time I set up my PC. Any thoughts on what the issue might be or how to fix it would be greatly appreciated, thank you!

CPU: Ryzen 5 3600x
Motherboard: MSI b450 gaming pro carbon max wifi
Graphics Card: RX 5600 XT
RAM: 2x 8GB Corsair Vengeance 3000 mhz.

Note: When I boot it in safe mode radeon software says "No AMD graphics driver is installed or the AMD driver is not functioning properly. Please install the driver appropriate for your AMD hardware". This error is strange since I downloaded the same drivers and they worked perfectly fine the first time I set up my PC.
Here's a link to a video of it crashing
View: https://youtu.be/d5DbQO4W1UA
 

ASK THE COMMUNITY

TRENDING THREADS