Question Issue with connecting 65-inch 4K TV to PC with HDMI cable ?


May 23, 2022

I am having big issue with connecting my PC to a 65-inch 4K TV via HDMI cable.

It was working great for couple of months but it stopped working properly yesterday. Right now, once connected with TV i am receiving some kind of weird artifacts. My PC is working fine with a regular AOC 27-inch LCD monitor. I was playing on TV mostly for some PC games in 4k and everything worked fine.

Some facts worth mentioning:

  • GPU is RTX 3070 Ti - drivers updated, no OC done.
  • I've bought new HDMI cable - 8K 5m (quite expensive). I checked with shorter cable - same result.
  • Bios updated - Motherboard MSI Z690
  • All ports in TV and GPU checked - same result.
  • TV ports are working fine i've checked with different PC.
  • GPU ports as well - checked with different devices.
  • I wanted to check if it will work with DisplayPort but TV does not have it and i don't have any hubs for that.
It seems that all devices are working properly but cannot connect together in the proper way.

I have no idea what could cause the issue so all your ideas are appreciated. Maybe there are some Bios functions that i am not aware of something.

Thank you in advance,

There is a photo and movie how it works.


Last time something like that happened(to a friend) the issue was that the daughter board/mainboard on the TV was what got fried. If changing the cables as well as using another port on the TV diudn't work then it's highly possible that your panel might be at fault.

Also, considering that this is a thread of troubleshooting nature, you're advised to include the specs to your build like so:
You've mention the AOC monitor but you didn't include the make and model of the TV. Stating BIOS version to be latest isn't exactly helpful to the issue, instead please state the version.

Have you tried using DDU to remove your GPU drivers, then manually reinstalling your GPU driver from Nvidia with the latest version in an elevated command, i.e, Right click installer>Run as Administrator?