Question Issue with EFI shell 'blockdevice' on HDD for Gigabyte Brix

Jan 15, 2021
10
0
10
0
Hello all

I have just bought a Gigabyte Brix (small PC)
model number is GB-BPCE-3350C
I have fitted a new 500GB seagate barracuda 2.5" drive (sata3) and 4gb of memory.

I have booted the unit using usb a few times but in all cases the HDD is not showing in the system.
There is only one sata port on the small motherboard,

The drive does show in the BIOS under HDD drives but when going into EFI Shell and mapping the drives the last line says 'blockdevice' for this drive.

I can not work out why the device is blocked.


Can anybody help or has any ideas?
 
UEFI system partition is needed for booting from a block device via UEFI
it doesnt mean device is blocked

if you bought new drive, it will need to be initialised first
if u have live cd linux , or windows PE which u boot from (OS with desktop on usb) then u will need go to drive manager and format your new drive
if u have windows 7/8 installer, and your drive doesnt appear there, u will need to load sata driver within windows installer (see your mainboard support page for windows sata drivers if it exists)
windows 10 x64 installer should have sata drivers for your board
 
Jan 15, 2021
10
0
10
0
That’s great. Thanks for helping me to understand.
To be honest I was trying to install a drive image of fedora 23 on the system as I will be using it as a media server - fedora 23 based software.
If I create a uefi partitition as advised and get the drive ‘initialised’ can I then go ahead and get fedora working? Or is this the wrong machine for this purpose?

many thanks for helping me to understand :)
 
it should work, linux is pretty highly compatible with anything
fedora 23 runs from grub2 bootloader, which supports uefi
no idea how fedora install looks like, if u have issues with it try follow this

sudo cfdisk /dev/sdb or whatever and make a 200MB EFI partition and a 500MB boot partition

then to make file system
sudo mkfs.vfat /dev/sdb1
sudo mkfs.ext4 /dev/sdb2


make some temp location and mount them so u can change content on them
sudo mkdir /mnt/boot2 /mnt/efi2
sudo mount /dev/sdb1 /mnt/efi2 && sudo mount /dev/sdb2 /mnt/boot2


then u need to get UUID for your drive, should be displayed at bottom
cfdisk
go to /etc/fstab and change UUID there

then use
efibootmgr to create boot entry in your uefi firmware (bios)
 
Jan 15, 2021
10
0
10
0
Well I have done a lot of trying and learning with this in the last 24 hours.

I have reached the point where I did successfully have it working but it is now refusing to work and I cant see why.

The drive is not showing up in the uefi / bios startup (del) screen under sata devices; (odd?)

When I use a ubuntu live usb to boot the system I can see the sata HDD drive. (there is only 1 sata port)

I have also put a correct boot record in the efi for the partition that I need it to boot with the UUID values etc...

I just cant work out why my computer is now not seeing the SATA drive at boot and so, i guess, cant boot the partition so it just goes to the efi shell>
 
can u boot in efi shell? if yes, go to bottom of this text (skip all this)

if your bios doesnt have it, u can download it from github
https://github.com/tianocore/edk2/raw/UDK2018/ShellBinPkg/UefiShell/X64/Shell.efi

get rufus to make uefi bootable thumb drive, format it as fat32

then go to your thumbdrive and make two folders:
efi -> boot
so your thumbdrive will have efi folder and inside it will be boot folder
go to that efi\boot folder and place here shell.efi u downloaded from github
rename it to bootx64.efi

you should have now efi shell bootable

once u boot to efi shell
post your screen
 
Jan 15, 2021
10
0
10
0
I don’t have fast boot in the uefi settings.
I do have ‘secure boot’ but I am not sure what this is. it’s enabled.
I don’t have an option the reset cmos in settings or on the board.
 
Jan 15, 2021
10
0
10
0
To confirm. I can see the HDD when I boot using a usb to Linux. And I can see the drive in drive manager. But it’s not showing up in bios/uefi - so it won’t boot.
 
Jan 15, 2021
10
0
10
0
Yes that’s correct - bios is F12.
I don’t understand how bios doesn’t see the disc but then when I boot the computer from a usb OS I can see the disc and it’s partitions.
doesn’t that seem strange?
 

ASK THE COMMUNITY

TRENDING THREADS