[SOLVED] Issue with front USB ports ?

liberty610

Distinguished
Oct 31, 2012
429
3
18,815
12
I have an issue with my 2 front USB ports, and I am not sure why. And now I think changing one of the USB options in advanced power mode to try and fix it is making my PC wake up from sleep mode by itself.

This is my full system on PC parts picker:
https://pcpartpicker.com/b/BqHhP6

So, my case has 4 USB ports on the top front part of the case. The first two are USB 2.0 ports that are not connected because this board only had one USB 2.0 header, and I had to buy a splitting adaptor cable for it to connect the control box for fans/LEDs. The USB 3.0 ports are connected, though.

I recently updated to the last BIOS of my motherboard, but have had this issue under every BIOS version i have had since I bought the board shortly after it originally launched. I also had this issue under Windows 10, and I am now running Windows 11.

The top USB ports give me issues with only certain devices. For example, if I plug in an external WD portable hard drive that is powered through the USB, it normally has no issues. If I plug in a Micro USB reader or my Android phone to one of these ports, it some times work, but more often than not, it will keep connecting and disconnecting. And this makes the Windows USB sound every time it connects or disconnects.

I looked this up online, and I tried changing an option. I went into control panel - power options - advance power options. I this section, I turned "USB selective suspend setting to "Disabled". Since doing this, the couple times I have tried using the front USB ports have been fine. It seems to not go into the disconnect/connect cycles. However, now my computer is waking itself up from sleep mode all of a sudden. I am not sure how much time goes by until it does, but prior to turning this selective suspend option off, I was able to put sleep mode on for several hours and it wouldn't wake up until I used the mouse or keyboard. Now it appears to be waking itself up randomly.

I also tried my USB micro SD reader in the front USB port, and it reads the Micro SD card, but then says "unrecognizable USB device" I can open files on it just fine, but I can't copy anything to it without getting an error message that says "there was a problem copying this item to the usb device" or something to that effect.

When using any of my motherboard's direct USB ports on the back panel, I never have any issues. It's just the two front USB ports that are connected to the motherboard's USB 3 header. Any ideas what is causing all this? I am assuming if I turn selective suspend setting back on, the PC will stay in sleep mode until I manually wake it. That setting is the only thing I change to where it started waking itself back up.

Thank you in advance for any replies.
 
I have an issue with my 2 front USB ports, and I am not sure why. And now I think changing one of the USB options in advanced power mode to try and fix it is making my PC wake up from sleep mode by itself.

This is my full system on PC parts picker:
https://pcpartpicker.com/b/BqHhP6

So, my case has 4 USB ports on the top front part of the case. The first two are USB 2.0 ports that are not connected because this board only had one USB 2.0 header, and I had to buy a splitting adaptor cable for it to connect the control box for fans/LEDs. The USB 3.0 ports are connected, though.

I recently updated to the last BIOS of my motherboard, but have had this issue under every BIOS version i have had since I bought the board shortly after it originally launched. I also had this issue under Windows 10, and I am now running Windows 11.

The top USB ports give me issues with only certain devices. For example, if I plug in an external WD portable hard drive that is powered through the USB, it normally has no issues. If I plug in a Micro USB reader or my Android phone to one of these ports, it some times work, but more often than not, it will keep connecting and disconnecting. And this makes the Windows USB sound every time it connects or disconnects.

I looked this up online, and I tried changing an option. I went into control panel - power options - advance power options. I this section, I turned "USB selective suspend setting to "Disabled". Since doing this, the couple times I have tried using the front USB ports have been fine. It seems to not go into the disconnect/connect cycles. However, now my computer is waking itself up from sleep mode all of a sudden. I am not sure how much time goes by until it does, but prior to turning this selective suspend option off, I was able to put sleep mode on for several hours and it wouldn't wake up until I used the mouse or keyboard. Now it appears to be waking itself up randomly.

I also tried my USB micro SD reader in the front USB port, and it reads the Micro SD card, but then says "unrecognizable USB device" I can open files on it just fine, but I can't copy anything to it without getting an error message that says "there was a problem copying this item to the usb device" or something to that effect.

When using any of my motherboard's direct USB ports on the back panel, I never have any issues. It's just the two front USB ports that are connected to the motherboard's USB 3 header. Any ideas what is causing all this? I am assuming if I turn selective suspend setting back on, the PC will stay in sleep mode until I manually wake it. That setting is the only thing I change to where it started waking itself back up.

Thank you in advance for any replies.
Try this step by step (read till end):
  • Disconnect from internet
  • Uninstall gpu driver DDU (clean and do not restart).
  • Uninstall all the processors (should be 32 on yours, also when it asks for restart, click on no) on device manager and the chipset in control panel like this:


  • Restart the pc to bios, and update to the latest bios. Then go to bios again after update and load default or optimized settings, then save and exit.

  • boot up to windows and install the latest Chipset driver, reboot and connect to internet.

  • Install the latest nvidia driver.

    *do this all offline until reboot after installing chipset driver, also you may reboot to bios after all of this to set the XMP (and previous settings you did). Download needed files (highlighted word) before doing step 1, do the step by orders.

  • Run cmd as admin, then do chkdsk /x /f /r, after that do sfc /scannow

  • And check windows update (and optional updates) if there is any and install them (except chipset in optional update). Enable hardware accelerated graphics scheduling (available in the latest windows update) in graphics settings and reboot, it should be like this:



  • Make sure the psu connected to the gpu is 1 pcie cable per 1 slot (use main cable, not the branches/split) like this:
 
Reactions: liberty610
I have an issue with my 2 front USB ports, and I am not sure why. And now I think changing one of the USB options in advanced power mode to try and fix it is making my PC wake up from sleep mode by itself.

This is my full system on PC parts picker:
https://pcpartpicker.com/b/BqHhP6

So, my case has 4 USB ports on the top front part of the case. The first two are USB 2.0 ports that are not connected because this board only had one USB 2.0 header, and I had to buy a splitting adaptor cable for it to connect the control box for fans/LEDs. The USB 3.0 ports are connected, though.

I recently updated to the last BIOS of my motherboard, but have had this issue under every BIOS version i have had since I bought the board shortly after it originally launched. I also had this issue under Windows 10, and I am now running Windows 11.

The top USB ports give me issues with only certain devices. For example, if I plug in an external WD portable hard drive that is powered through the USB, it normally has no issues. If I plug in a Micro USB reader or my Android phone to one of these ports, it some times work, but more often than not, it will keep connecting and disconnecting. And this makes the Windows USB sound every time it connects or disconnects.

I looked this up online, and I tried changing an option. I went into control panel - power options - advance power options. I this section, I turned "USB selective suspend setting to "Disabled". Since doing this, the couple times I have tried using the front USB ports have been fine. It seems to not go into the disconnect/connect cycles. However, now my computer is waking itself up from sleep mode all of a sudden. I am not sure how much time goes by until it does, but prior to turning this selective suspend option off, I was able to put sleep mode on for several hours and it wouldn't wake up until I used the mouse or keyboard. Now it appears to be waking itself up randomly.

I also tried my USB micro SD reader in the front USB port, and it reads the Micro SD card, but then says "unrecognizable USB device" I can open files on it just fine, but I can't copy anything to it without getting an error message that says "there was a problem copying this item to the usb device" or something to that effect.

When using any of my motherboard's direct USB ports on the back panel, I never have any issues. It's just the two front USB ports that are connected to the motherboard's USB 3 header. Any ideas what is causing all this? I am assuming if I turn selective suspend setting back on, the PC will stay in sleep mode until I manually wake it. That setting is the only thing I change to where it started waking itself back up.

Thank you in advance for any replies.
Try this step by step (read till end):
  • Disconnect from internet
  • Uninstall gpu driver DDU (clean and do not restart).
  • Uninstall all the processors (should be 32 on yours, also when it asks for restart, click on no) on device manager and the chipset in control panel like this:


  • Restart the pc to bios, and update to the latest bios. Then go to bios again after update and load default or optimized settings, then save and exit.

  • boot up to windows and install the latest Chipset driver, reboot and connect to internet.

  • Install the latest nvidia driver.

    *do this all offline until reboot after installing chipset driver, also you may reboot to bios after all of this to set the XMP (and previous settings you did). Download needed files (highlighted word) before doing step 1, do the step by orders.

  • Run cmd as admin, then do chkdsk /x /f /r, after that do sfc /scannow

  • And check windows update (and optional updates) if there is any and install them (except chipset in optional update). Enable hardware accelerated graphics scheduling (available in the latest windows update) in graphics settings and reboot, it should be like this:



  • Make sure the psu connected to the gpu is 1 pcie cable per 1 slot (use main cable, not the branches/split) like this:
 
Reactions: liberty610

ASK THE COMMUNITY