Question Issue with my Internet (Ethernet) disconnecting after a random amount of time when a Minecraft Server has people on it

Jan 9, 2021
1
0
10
0
Hopefully the title describes the problem, essentially when my 1.16.4 Minecraft server runs (with people on it from a different network), after a random amount of time (sometimes it 5 minutes, but the longest I've been able to go is around 4 hours), my internet connection (which is ethernet) will completely disconnect. The server itself is fine (as when I join via localhost, OR local ip address) it doesn't kick me out, but everyone else who connects via my public IP (and when I too join via my own public IP), will be kicked out (obviously right? Since it's my internet that no longer works). In addition nothing irregular with server logs so I'm fairly certain the server isn't the issue, but more so something with Windows 10 and people connecting via an outside network.
I would like to mention that perhaps around 2-3 months ago this problem didn't exist, and only suddenly started to happen when I got a new computer, so this makes me believe that it's something with THIS computer and not the router.
Whenever the ethernet disconnects, stopping the server does nothing, neither does disconnecting the cable. I have to completely restart Win10 in order to get my connection back.
Things I have tried--->
I have tried completely disabling Windows Defender Firewall, and having it on with Java as an exception, neither proved to be the solution. I googled and found this thread, where someone suggested to edit my ethernet adapter settings and change the value of "number of transmit buffers" to 512. (this was already the default). However I don't think this is the issue as regardless if there is one person on the server or 10, the result is the same. This is also an issue with multiple version of Minecraft, (have played on 1.12 and 1.16) which further makes me believe that its not a problem with the server, but more so something with windows.
Here is an image of the network adapter settings
I would like to iterate that this issue only occurs when I'm port forwarding, other than that I have incredibly stable internet regardless if I'm just browsing the internet, in a Zoom call, or playing any other game.
If there is any further information I can provide please ask, but as for now here is what I can think off of the top of my head: Device name -------
Processor Intel(R) Core(TM) i7-10700K CPU @ 3.80GHz 3.79 GHz
Installed RAM 16.0 GB
Device ID -----------------------
Product ID -----------------------
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display
Edition Windows 10 Pro
Version 20H2
Installed on ‎2020-‎10-‎21
OS build 19042.685
Experience Windows Feature Experience Pack 120.2212.551.0
 

ASK THE COMMUNITY

TRENDING THREADS