Question Issue with "OverPowered" 17-inch Laptop & Nvidia Control Panel not displaying all options, can't change refresh rate etc. ?

NatoGhost

Distinguished
Dec 21, 2009
3
0
18,510
0
I have the problem where in many games, regardless of my video settings, my FPS will not go above 60. I believe this is because of some software limit. I have tried numerous things to fix it.

I am running an "OverPowered" 17" Laptop with an onboard integrated Intel video card and a Geforce GTX 1060. It's running Windows 10. I pretty much only use my laptop while plugged in, so I have tried disabling the intel card in an attempt to fix this issue (or what I thought were related issues) without success. When I go into my display settings in Windows, it shows my display at 144 hz. I've gone to a website that tested and reported my display at 144hz. I've changed my settings in games from Ultra to Low and still get 60 FPS, so I don't think that's my legit max'd FPS.

This leads me to the issue in NVIDA Control Panel.... I dont have all the options. I've googled and found this is common in laptops with multiple GPUS. I have tried all the options listed here:


Although when going into my BIOS I did not have the option for a default graphics adapter. The bios this laptop uses is the Aptio Setup Utility. I tried hitting A right when it opens but it seems like it's showing all options but doesn't have that?

So just to clarify, I uninstalled reinstalled my Nvidia drivers. I disabled/enabled the onboard Intel card with no noticeable difference. I went into the Nvidia control panel and turned Vsync off and also made sure my GeForce 1060 was the preferred graphics processor. I also set it for the specific game I was running into this with today (Holdfast, Nations At War).
I'll try to post a screen shot of my Nvidia Control Panel. I confirmed in task manager it's using the correct 1060 now but still capped at 60 FPS.

This is my laptop:

https://www.walmart.com/ip/OVERPOWERED-Gaming-Laptop-17-2-Year-Warranty-144Hz-Intel-i7-8750H-NVIDIA-GeForce-GTX-1060-Mechanical-LED-Keyboard-256-SSD-2TB-HDD-32GB-RAM-Windows-10/887474519

Thanks for your time.
 
Last edited:
Jul 12, 2021
18
4
15
0
I have the same laptop as you. What is your bios version? Update your windows to latest. Try updating your bios to this latest version and see if it helps. Use the latest Nvidia Gamer Ready Driver but first uninstall your current Nvidia driver completely using DDU Tool by going into boot mode, and then install the latest Nvidia driver after booting to windows. Also, uninstall Geforce Experience if you don't use it! If you need any help let me know.
 

ASK THE COMMUNITY