Question Issue with recent Nvidia drivers

I have this weird issue with the more recent Nvidia drivers. The issue first seemed to present when I updated by GPU drivers to play Detroit Become Human, I updated to the third latest version right now, 445.87(at the time it was second latest). That game had no issues. Then I recently updated further to the newest drivers, 451.48, and I have so far had this issue in two games - Sleeping Dogs and Grid 2.

The issue is that when I overclock my monitor to run at 74 Hz instead of 60 Hz, the games refuse to go fullscreen no matter what. Reverting to 60 Hz resolves the problem. Nothing else seems to fix the issue - changing in-game settings, pressing Alt-Enter. Either it will run 74 Hz in Windowed mode or 60 Hz in Fullscreen or Windowed. 74 Hz at fullscreen just doesn't happen.

So, I decided to try a clean install of the drivers using DDU to remove the latest version, but instead of getting the latest drivers I got older drivers from Nvidia's website, a release from February of 2020, 442.50. Oddly enough, the issue does not happen with these drivers installed - I can play fullscreen at 74 Hz no problem. Does anyone else experience this issue, or would this just happen to be game-specific for the few games I've tried? Right now I'm just using the drivers from February since I have no problem with having slightly outdated drivers, performance seems unaffected.
 

boju

Polypheme
Ambassador
Have you tried overclocking refresh a little to say 5Hz higher to see if monitor overclocking in general is borked in the latest driver series? If it is, id get onto Geforce driver feedback forum and let them know.

Are you using CRU to overclock?

Im wondering whether sync options in NvidiaCP could be affecting the OC, maybe try mess with different settings, on, off, adaptive/fast, app control etc and that other low input latency mode setting.
 
Have you tried overclocking refresh a little to say 5Hz higher to see if monitor overclocking in general is borked in the latest driver series? If it is, id get onto Geforce driver feedback forum and let them know.

Are you using CRU to overclock?

Im wondering whether sync options in NvidiaCP could be affecting the OC, maybe try mess with different settings, on, off, adaptive/fast, app control etc and that other low input latency mode setting.
I haven't tried 5 Hz higher, but I did try 73 Hz instead of 74, and the issue remained. To test with like 65 Hz I'd have to again install the newer drivers and then go back to the previous ones. But can I go from new drivers to older ones without using DDU?

I'm using Nvidia Control Panel to create a custom resolution with 74 Hz. What settings in Nvidia Control Panel do you want me to mess with specifically? I'll install the latest drivers first and try 65 Hz and let you know.
 
Welp, nevermind. Looks like using DDU has resolved the issue permanently. Upon updating to the latest drivers from the February version, I went straight to 74 Hz after a restart(had to create the custom resolution again) and Sleeping Dogs now runs fullscreen. Don't have Grid 2 installed anymore but I think it's okay now. Thanks for the help @boju! :)
 
Jul 1, 2020
1
0
10
0
Please i really need ur help, i downloaded sleeping dogs on my pc from R G mechanics but i could not launch the game after the download
intel pentium
ram: 4gb ram
GPU: 1.33hz
Please i really need ur help on dis.
 

ASK THE COMMUNITY