Question Issue with ssd and fan hub plugged into 1 sata power cable.

Sep 8, 2019
4
0
10
0
Wasn’t sure which catergory to put this in but I recently purchased an antec 3 in 1 rgb fan pack to put in my pc. The fans connect to a hub which connects to the safe power cable and a motherboard fan header. I only have one sata power cable for my EVGA 500w 80+ bronze power supply so I have my ssd and the fan hub plugged into that. When I first installed the fans everything worked fine but I unplugged it and redid the cable management. After reinstalling it I turned on my pc and it took me to my bios and my pc can no longer read my ssd drive unless I unplug the fan hub. Please help me figure this issue out. It’s very frustrating.
 
Sep 8, 2019
4
0
10
0
The power supply can connect 2 sata power cables, however, I only have 1 so I assumed I could just plug the ssd and fan hub into that one cable. Is that not correct? If not why even ad 3 connectors on the cable.
 

Barty1884

Titan
Moderator
You should be able to, yes... but in the event you're having issues, you could try using the secondary cable/chain.

IIRC, you can draw 4-5A via each connector, by spec... which is more than enough for a drive, or fan hub etc under normal conditions.
 
Sep 8, 2019
4
0
10
0
So any ideas on what is causing my problem though? Basically it all works fine not Together. And I looked online for an evga sata cable for my power supply and all of the cables sold by themselves said they can’t be used in a semi modular power supply. So any suggestions on where to buy another cable if that’s the cause if the issue. And I do not want to buy a whole set of cables.
 

Barty1884

Titan
Moderator
Not 100% sure. Could be a defective hub etc, attempting to draw out of spec power.
In theory, there shouldn't be any problems....

Which PSU do you have, specifically?

I'm not aware of any 500W EVGA units that only have the one cable. I don't doubt one exists, but the W, the B2, the BR etc all have two chains with 3 connectors each...
 
Sep 8, 2019
4
0
10
0
My power supply is the EVGA BQ 500 W 80+ bronze certified semi modular ATX power supply. It has two sata slots but I only received 1 sata power cable for it. And the fan hub, fans and rgb for them work perfectly fine but I just can get my pc to read my drive so I don’t think it’s a faulty hub or anything
 

ASK THE COMMUNITY

TRENDING THREADS