Issues loading Desktop applications

Dec 26, 2018
4
0
10
0
Dear Community,

I have recently built myself a gamer PC. Since a few days, my desktop icons and applications are not being loaded correctly when my computer starts. At the beginning, when the desktop appears, I can only see my Screen-Wallpaper and approximately one and a half minute later, the icons suddenly appear and applications start. This is obviously not normal as my PC is quite new, powerful and not many programmes are installed yet. Startup mode in BIOS is set to Ultra-fast and my windows is installed on a separate SSD hard drive.

Any ideas what this could be?

Cheers,
Almundo
 

Traditore

Honorable
Nov 5, 2013
516
31
11,190
82
Something is taking so long to load that it delays everything else.

Disable autostart at boot for all your installed programms.

Or just try the CLEAN BOOT

And BTW, do you see a network connection icon in the taskbar before all icons appear? What is it showing? I knew a few cases when a faulty LAN driver was causing such a slow boot=delay.
 
Dec 26, 2018
4
0
10
0


Ok, will try that. Another thing is, when I restart my PC while the desktop is getting loaded, windows starts normally and everything gets displayed correctly.

 
Dec 26, 2018
4
0
10
0
Ok so I disabled Ultra Fast Boot in my BIOS and set it back to normal Boot. Everything gets loaded correctly now. I guess something doesn't load as it should when windows starts that quick.

@ Traditore : I checked if the network icon connection appeared while the desktop is loading and yes, it does. All normal icons , nertwork, sound, keyboard language and time appear. However, the loading symbol at the mouse cursor appears while loading.
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS