Issues Port Forwarding on Spectrum "Wave 2" RAC2V1S Router

thelastadvacado

Commendable
Apr 18, 2016
3
0
1,510
0
Hello, I am having issues forwarding ports on my router, I have tried many online guides to no avail and am just about at my wits' end. I'm currently trying to forward some of my ports for hosting gaming servers for me and some friends, however no matter what I try (port forwarding, "port triggering" (whatever that is), and even putting my device as a "DMZ"), I don't seem to be having any success. So here's where I'm at/what I've tried:

I have been able to access my router's configuration menu successfully, and through the "Access Control" menu I am able to use a "Port Forwarding" menu as well. In an effort to get literally any port to work, I have created 2 custom rules (one for TCP and another for UDP) with service as "other", external host blank, external ports from 1-65535 (yes, for testing purposes I have tried opening ALL of my ports, I figure I can change it to something specific if/when it works), internal host as 192.168.1.7 (my ipv4 as listed by ipconfig), and internal ports from 1-65535 (again, all). To summarize, each field reads as:
Service: Other
External Host: *
Internal Host: 192.168.1.7
External Port: 1-65535
Internal Port: 1-65535

In addition to the seemingly obvious solution of forwarding my ports through the "Port Forwarding" menu, I also tried through a menu called "Port Triggering", filling in the fields as follows:
Trigger Protocol: TCP/UDP (one service for each)
Open Protocol: TCP/UDP (one service for each)
Trigger from Port: 1
Trigger to Port: 1
Open from Port: 65535
Open to Port: 65535
(yes, I also tried to trigger/open all of them here too, please let me know if I'm my own enemy here or not)

Lastly, despite security concerns, I decided to try and DMZ my desktop. To do this, I simply entered my my ipv4 address (192.168.1.7) and it recognized it as my desktop.

Despite trying all three of these honestly questionable solutions, I have had zero success when trying to test if any of my ports are open, both when friends have tried connecting to my servers as well as when I have tried testing my ports through the "open port check tool" site. It's also worth noting that my router seems to be either a very new or very weird model of spectrum router, as the interface is totally different than what I've seen online looking at guides for other spectrum routers (most are for a "RAC2V1K" wave 2 router, which has entirely different menus and options). I am kind of a novice at this, so I am absolutely expecting that I've missed something really basic here, and I'd appreciate any help or suggestions. I also have images of each part of what I've posted, and I'll attach them as soon as I figure out how, if possible. Thanks in advance for any assistance, I appreciate it.
 
Best to test with DMZ mode first since it is the simplest.

Open ports require both the data to be able to pass through the router AND the server the data is sent to must respond to the probe packets. You generally must have a program running on the pc listening to the port. There could be firewall setting blocking this also.

So first step is always to verifty that the external IP your router sees is the same as sites like whatsmyip reports. If they are different your ISP is doing NAT in the path and you will never get port forwarding to work.

After this you need to see if you pc is getting the data or not so you know if you need to look at router or pc settings. The best way tends to be loading wireshark onto the pc. It brute force captures all the data coming and going to your computer. You will see the probe packets being sent to your machine even if it does not respond. You need to run as little as possible on your pc when you have wireshark running to avoid huge capture files. It can be easily filtered but then you must learn to do that so it is simpler to just keep traffic to a minimum.

 

thelastadvacado

Commendable
Apr 18, 2016
3
0
1,510
0

Hey, thanks for the response. So I've gone and checked my IP address as listed on whatsmyip, and it lists three values for my IP addresses:
Your Public IPv6 is: 2605:a000:140e:834e:945f:cd90:95c7:15b5
Your IPv4 is: 184.59.17.249
Your Local IP is: 192.168.1.7

I'm not exactly sure how to verify what my router sees, but running ipconfig it lists my IP values as:

Connection-specific DNS Suffix . : home
IPv6 Address. . . . . . . . . . . : 2605:a000:140e:834e::1000
IPv6 Address. . . . . . . . . . . : 2605:a000:140e:834e:3d91:87f8: d4e2:63b4
Temporary IPv6 Address. . . . . . : 2605:a000:140e:834e:945f:cd90:95c7:15b5
Temporary IPv6 Address. . . . . . : 2605:a000:140e:834e: dc66:e58b:a67b:2cd8
Link-local IPv6 Address . . . . . : fe80::3d91:87f8: d4e2:63b4%9
IPv4 Address. . . . . . . . . . . : 192.168.1.7
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : fe80::aa9a:93ff:fe92:bd2a%9
192.168.1.1
When I log into my router, I do see that 184.59.17.249 is listed as my "public ipv4" address as well, with 192.168.1.7 as my "private ipv4".

I believe I am currently running my desktop as DMZ, and testing whether any ports are open returns negative, though maybe I'm missing something other than setting it up in my router's configuration menu.

I also installed wireshark to check traffic, but I definitely feel that I'm out of my depth with the interface, and I'm not really sure what exactly I'm setting it up for or how to do so.
 
I would disable the ipv6 support in the nic. It is not likely your problem but it makes troubleshooting harder.

Wireshark is very complex to learn to use but what you are looking for is bunch of traffic that start when you run a port scan from a site on the internet.

It is hard to describe, wireshark will actually decode all the data but all you are looking for is a bunch of packets coming from a ip on the internet being sent to a bunch of ports. It looks very different from say traffic coming from capturing web surfing. This is one of those thing that you must play with it for a while. You don't even need to understand the data just when you see traffic and when you do not. A port scan sends quite a bit a traffic in a short burst so it tends to be obvious.
 

ASK THE COMMUNITY

TRENDING THREADS