Issues with Black Screen of Death post upgrading on Win 10

Feb 5, 2019
3
0
10
0
Folks, I seem to be facing a problem with an home built system. I recently upgraded the motherboard to an ASROCK X470 SLI/AC, replaced the ram modules to GSkill (3200 8gb+8gb total 16gb), an Radeon RX560 display card, AMD ryzen 1700X 8 core processor and retained the rest of the hardwares a Bluray drive, WD 2tb hdd having win 10 on an MBR partitioning with the same PSU 450W.

All seem to be working fine on powering on but during usage all of a sudden I get "Black screen of death" with no activity at all on the computer. I have to shut off the power and restart every time. I have updated all drivers and softwares unsure what is causing this issue and totally confused.

BTW I am suspecting a few things the ram in bios is showing 2400 when the ram installed is DDR4 3200 (PC4 25600) I have it slotted in for #2 and #4 according to the specs of a summit ridge processor.

Other thing I am facing is Bluray Rom drive that was working now is constantly reading with no disk in it or keeps accessing repeatedly. I am unsure on this too.

Need help to get this resolved and appreciate it.

 
Feb 5, 2019
3
0
10
0
thanks for the response. Is there anyway I can reinstall windows 10 without having to lose the custom applications like office suite or 3 party apps licensed as dont want to lose all my installed apps and personal files.
 
Feb 5, 2019
3
0
10
0
I did an reinstall of Win10 on the existing installation keeping the personal files. It is working great and dont seem to be facing issues. Also there were so many inherent issues before like Photos app not working, BlackSOD, DVD-ROMS sometimes working and not working, hibernation issues, etc. All seems to have resolved post this reinstall and seems to be working perfect. Many thanks to @Norcalsc for the timely suggestion
 

Similar threads


ASK THE COMMUNITY