Question Issues with games freezing with External SSD on Laptop ?

Oct 13, 2020
1
0
10
0
The SSD is the Seagate Barracuda 500GB SSD. This issue is almost universal with all games, with only one partial exception. The video and audio will frequently pause and become out of sync, which causes the game to briefly freeze. This does not occur on my Internal SSD or External HDD. I do not know much about external storage, but I have attempted extensive troubleshooting. The issue only occurs when the SSD is connected to my USB 3.0 port. When connected to the 2.0 slot, this issue does not occur, although predictably loading times become far longer. I have two USB 3.0 slots. They both appear in device manager, and after extensive testing I do not believe that they are linked. The issue still occurs when the External SSD is the only thing plugged into the laptop. I recently reinstalled drivers for the USB ports when I first encountered this issue. The cable for the SSD is a USB-C to USB-A 3.0 cable. The file type for the SSD is NTFS. I have enabled write-caching.

Here's the benchmark with only the SSD plugged in:


[Read]
Sequential 1MiB (Q= 8, T= 1): 459.947 MB/s [ 438.6 IOPS] < 18200.45 us>
Sequential 1MiB (Q= 1, T= 1): 405.846 MB/s [ 387.0 IOPS] < 2581.91 us>
Random 4KiB (Q= 32, T=16): 118.532 MB/s [ 28938.5 IOPS] < 17635.39 us>
Random 4KiB (Q= 1, T= 1): 21.923 MB/s [ 5352.3 IOPS] < 186.47 us>

[Write]
Sequential 1MiB (Q= 8, T= 1): 134.432 MB/s [ 128.2 IOPS] < 43057.96 us>
Sequential 1MiB (Q= 1, T= 1): 205.104 MB/s [ 195.6 IOPS] < 4455.58 us>
Random 4KiB (Q= 32, T=16): 60.733 MB/s [ 14827.4 IOPS] < 30147.22 us>
Random 4KiB (Q= 1, T= 1): 10.087 MB/s [ 2462.6 IOPS] < 269.42 us>

Profile: Default
Test: 1 GiB (x5) [Interval: 5 sec] <DefaultAffinity=DISABLED>

Here's the benchmark with external SSD, external HDD, and mouse plugged in:

[Read]
Sequential 1MiB (Q= 8, T= 1): 459.550 MB/s [ 438.3 IOPS] < 18214.72 us>
Sequential 1MiB (Q= 1, T= 1): 405.735 MB/s [ 386.9 IOPS] < 2583.49 us>
Random 4KiB (Q= 32, T=16): 118.082 MB/s [ 28828.6 IOPS] < 17700.51 us>
Random 4KiB (Q= 32, T= 1): 118.719 MB/s [ 28984.1 IOPS] < 1102.71 us>

[Write]
Sequential 1MiB (Q= 8, T= 1): 226.060 MB/s [ 215.6 IOPS] < 32975.86 us>
Sequential 1MiB (Q= 1, T= 1): 212.237 MB/s [ 202.4 IOPS] < 4395.03 us>
Random 4KiB (Q= 32, T=16): 50.380 MB/s [ 12299.8 IOPS] < 33790.62 us>
Random 4KiB (Q= 32, T= 1): 58.669 MB/s [ 14323.5 IOPS] < 1939.32 us>

Profile: Default
Test: 1 GiB (x5) [Interval: 5 sec] <DefaultAffinity=DISABLED>


From other benchmarks I have seen, the read speed seems normal, while the write speed seems about halved.

Here are my specs: https://valid.x86.fr/aykyc6

Any help would be appreciated.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS