Issues with Maxis Fibre Internet

kangshaun

Reputable
Jun 30, 2015
8
0
4,510
0
Greetings,

I'm not sure if this is the right section so excuse me for that.

I'm currently using Maxis Fibre Internet and have been experiencing issues with it lately. I'm unsure as to whether it is in fact my internet provider or that fact that I'm using Windows 8.1. The issue I'm having is it being limited frequently and having to troubleshoot to fix it every time. Now it has gotten worse up to the point where sometimes my laptop can't even find the network. And even when it does, it can't connect and when it does connect, it shows 2 bars of signal but still doesn't let me access the internet, giving me the DNS PROBE FINISHED NO INTERNET error.

If there's anyone using Maxis Fibre that can clarify some things for me and help me with this, it would be really appreciated.
Even if you don't use Maxis Fibre, some help to fix this would certainly be appreciated as well.
Thanks in advance.
 

kangshaun

Reputable
Jun 30, 2015
8
0
4,510
0


I guess not, it's a router. If it's possible, I'm not sure how to. It's weird because other users in my house are able to connect and use fine bar a few disconnections every now and then.
 

kangshaun

Reputable
Jun 30, 2015
8
0
4,510
0


Didn't have to. Disabled bluetooth in PC settings and did some things in the command prompt and now it seems to work, although there's a limited sign on it. And the signal strength range is lower now.

Can't get rid of the limited sign even though I tried troubleshooting.
 

ASK THE COMMUNITY

TRENDING THREADS