Issues with port forwarding on Arris tg862g/ct


Oct 2, 2012
Let me begin by saying that I realize this is not a good router. It is the one that I was given when I had xfinity installed. Ever since then, I have been having issues, most of which I was able to resolve. Before I switched to xfinity, I ran a minecraft server for some kids in my neighborhood, and port forwarding on FIOS was a breeze. However, on xfinity the port forwarding seems to have no effect. I port forward on port 25565, but even when I enable this, the port stays closed. I ran tests on, and it cannot access the port. I realize this may just be because of the router, and that I might need to buy a new one. I hope that this can be fixed, because I'd rather not spend any more money.


Jan 25, 2012
Check out this port forwarding guide, it doesn't have your exact model number but it should give you a picture of what you need to do. Although I doubt it is the port forwarding on your router just have a look to be sure.

Otherwise you may have to look into the firewall, UPnP, QOS settings on the router just in case something is blocking you there. Actually you can also try putting your IP in the DMZ to see if the connection works, that way you will at least know the issue is comming from your router and not the PC.
Also check your computer's security software, that may also be causing the problem.