Question Issues wth new monitor in games

Metalrocks

Reputable
Nov 13, 2014
107
0
4,680
0
I got my self a new monitor.
https://www.pccasegear.com/products/36624

I have a AMD R9 290x. Latest drivers installed.
I know, not the newest but still holds up.

so far so good. I thought to use Freesync I need a display cable, but for some reason it did not work as it states that it does not get a signal. I had to use a HDMI cable instead. I also installed the drivers for the monitor.

Never the less, Freesync is on when I checked in the Radeon settings. All fine so far but with Resident Evil 2 remake it causes some issues. The screen turned black after every 5 to 10 seconds and back again after 10 seconds or longer. The resolution in the game was over 3000 and i could not change it. After disabling Freesync, I could finally play the game.

I have played Shadow of the Tomb Raider with Freesync on and super resolution. and the game ran fine, but the resolution is still set to 1920x1080.

Other games I did not try out yet but I wonder why using a Display cable does not work, even when my card clearly has a connection. What I am also not familiar with is the pixel format in the Radeon Settings. Currently its set to "YCbCr 4:4:4 Pixel format".

So what settings do I need to change in Windows ( I use Win 7 64bit) and in the game(s).
 
Last edited:

Lutfij

Titan
Moderator
Your link doesn't work for me.

Mind sharing your system's specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:
Monitor + Resolution:

Which driver version are you running for your GPU?
 

Metalrocks

Reputable
Nov 13, 2014
107
0
4,680
0
Strange. Anyway, this is the monitor:
AOC AG322FCX FHD 144hz FreeSync Curved 32in VA Gaming Monitor


As stated above, I have win 7 64 bit.
R9 290x 4gb ram
16GB RAM
i7 4790
HDD

Resolution I have now is 2560x1440. I had before 3200x1800 but the writing was small and looked like small ants were over the letters, making it hard to read. Even when windows recommends 1920x1080, everything is just too big and videos look almost pixelated. Not very nice on the eye.
 

Metalrocks

Reputable
Nov 13, 2014
107
0
4,680
0
Test another displayport cable. If you get video then the problem was with the cable. If you don't get video, then the issue is with the port on the graphics card and will have to be returned for RMA.
The cable is brand new, as it was included with the monitor. I did try out a new one but the result is the same. HDMI is the only one that works.
Cant return the card as I have it for several years.
 

Metalrocks

Reputable
Nov 13, 2014
107
0
4,680
0
Looks like the displayport is dead. I guess one day I have to get a new GPU were I can hopefully use it.
Still weird thought as I have never used display on the card since I got it.
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS