Question Isuue with BIOS and OS

joshua.arin

Prominent
May 29, 2018
7
0
510
0
My motherboard is Strix b350f, I have installed my os on my M.2 SSD but my bios is not showing my SSD, Boot priority option on EZ mode in bios only showing my HDD and my disk drive but not my SSD and in the advanced mode of my bios boot oprion#1 is showing my HDD and boot option#2 is showing my disk drive, but it suppose to show my SSD...DO note that there are currently 2 HDD installed in my pc one is 1tb (7200rpm) other one is 2tb (5400rpm) however my os is still booting but sometimes I face blue screen and sometimes when os is updating I face a warning message in bios says "Please back up your data and replace your hard disk drive. A failure may be imminent and cause an unpredictable fail. Press F1 to run setup" when I press F1 it goes to bios menu then I press F10 without changing anything and my os boot just fine... When I face blue screen issue then it says "File:\Windows\System32\drivers\Storahci.sys error code: 0xc0000185" I have already reinstalled windows for this issue but facing this issue again but occasionally sometimes I can boot in my OS sometimes I can't...Please note that I have just updated the bios to the latest version haven't faced the issue yet but SSD is still unrecognized and boot time is higher than usual and pc is running slow though os is on my SSD...I have also checked my all the drive HDD and SSD with Crystal Disk Mark info nothing unusual there...Seems everything working fine there...If you know how to solve this issue please do let me know, I will be very glad if I can solve this issue without claiming the warranty process...Thanks in advance...
My Specs: Ryzen 5 1600
Motherboard: ROG Strix B350F
Ram: Gskill Trident Z 3200 MHz
SSD: HP EX900 M.2 250 GB PCIe NVMe
PSU: CM MWE 450w
GPU: ROG Strix RX 560 4 GB
 

joshua.arin

Prominent
May 29, 2018
7
0
510
0
did you unplug the other HDD when you install Windows to the SSD?
what the bios version on the motherboard?
Thanks for the reply...No, I did not unplug the HDD while installing windows however I found the option in bios menu to make SSD my boot priority and selected the SSD in the boot option 1 while boot option 2 is my disk drive, The bios version of my motherboard is the latest one 5204, Have not faced any issue yet as i have rolled back to the previous build of windows from 1903 to 1803
 

ASK THE COMMUNITY