I've got a serious problem trying to reinstall windows 8.1 with Linux Mint

Jessedavid4

Honorable
Dec 12, 2012
28
0
10,530
0
Okay, so I have no idea how to really explain this, so I am going to start with how it happened first. So I installed the new Linux Mint 18 on my HDD as a dual boot and in doing so it wiped my windows 8.1 (don't worry this happens 9/10 times for everyone). I did backup my windows and all my files.

Now, what I need to do, is reinstall windows. But I am having many many issues trying to reinstall. (btw this is like the 30th time I've reinstalled windows in the last year, mainly due to new hard drives and Linux systems. Though it doesn't bother me, I've just never hit a roadblock this big before that I cannot get past it).

So I insert the media disk for windows 8.1. I get up to the install, put in the code, accept terms and then I am at the partition page. This is where I am stuck. (like I said, this hasn't happened before, so in other words I think I know what I am doing with partitions) So in my Mint options, I decided to add a partition to the back up-files-drive so I can reinstall windows on there.
So I go back to the media disk installation and try to select that partition of that drive. And I keep getting the error: "windows cannot be installed to this disk selected disk is of the gpt partition style" . (before you start asking, yes -- I did make sure I had my bios has UEFI on and supported. As well that my disk and partitions were set up to support the boot compatibility UEFI)

So generally this is where I am stuck. Another thing, I am not planning on installing it on the HDD and dual boot because the chances of installing windows and wiping my linux mint files and OS are extremely high. (I personally feel there is hatred between Windows and Linux so this crap happens all the time)

1 more thing, yes I tried to reformat the partitions and no windows still cannot recognize it.

I've never had an issue like this before, any help would be appreciate beyond satisfaction!

Thanks!
 

Faux_Grey

Honorable
Sep 1, 2012
747
0
11,360
168
Turn OFF UEFI secure boot in the BIOS.
When windows install sees UEFI available, it will force it in the installer and complain if it can't get what it wants.

Linux has formatted your disk as GPT, so windows won't install to it on a motherboard that support UEFI.


I find the easiest way to dual boot is to Install windows first as GPT, then re-partition the drive in windows so you have 30Gb of free space or so for linux.

Then pop in your linux usb drive, and boot from that.

In the Linux installer you'll get the option to "do something else" with your disk rather than wiping it, select that.

On that screen you'll create a new partition on your primary hard drive inside the free space that you made in windows, click the plus arrow to do this by "free space"

Make one partition at the "front" (beginning of disk) with the rest of the space formatted as EXT4 with /
it then asks you which device to install the bootloader (/dev/sd*)
Find the /dev/sd code that matches the / parition of that you made and select that as where you want the bootloader.

Complete the install as normal.

When rebooting it should put you straight back into windows, giving you no offer for Linux, great!

Now use a program called EasyBCD (http://www.techspot.com/downloads/3112-easybcd.html) to add the linux bootloader to the windows one.

Add new entry -> Linux/bsd -> Grub -> Select the linux-sized partition from the drive list and name it whatever you want.

(I forget if I used grub1 or 2, but it is safe to add an entry for both and then delete the one that doesn't work)
 

ASK THE COMMUNITY