I've tried everything... PC turns on for only a second

Mar 29, 2018
I'm not new to this game and I'm stumped, so I've recently got an old HD 7870 back from a friend as they've upgraded, it's in fully working order (tested personally with their system) and I thought I could sell it on eBay for a quick buck, so I decided to self refurbish it, deep clean, new thermal paste, grease the fan bearings, the works, make it basically factory new.

Take my GTX 970 out, put the HD 7870 in, booted up fine, detects the card fine, realise I forgot to uninstall the Nvidia driver, start menu > power > holding shift + restart so I can boot into safe mode, PC turns off and it hasn't managed to turn on properly since.

It will turn on and turn off immediately, literally within a second and will just keep turning on and off over and over till I kill the power, I have done absolutely everything I can think of;

Baseboarding the build, taking it all out and placing it on a motherboard box, completely minimal boot, moving the ram sticks around in all possible configurations, digging out a motherboard speaker to check the motherboard by trying to boot without any ram but the PC won't stay on long enough for the speaker to make any noise, taken the CPU out and checked for any bent pins, reapplied thermal paste properly, different GPU configurations, all different PCI-,E slots, internal DVI, HDMI, reset CMOS, tried with and without battery, tried different CMOS batteries, left the computer to discharge fully, checked the cables, tried multiple power cables, different outlets, tested the PSU with a paperclip and is ok, tried with nothing but power, no cpu, gpu or ram, no matter what I do it will not power for more than a second, I've gone through that 21 step no post list thoroughly and still nothing.

I'm really losing my mind here

I personally think the old HD 7870 has managed to fry my Mobo magically somehow...

Important specs;

PSU: Corsair VS650W
CPU: i5 3570k
RAM: 16GB Team Group Elite DDR3

The system was working perfectly fine before swapping GPUs.

Any help is much appreciated thanks.


I assume this is what you meant by "left the computer to discharge fully", and it's probably grasping-at-straws, but, if you haven't already, try this:

1 - Unplug PC.
2 - Remove CMOS battery.
3 - Hold down power button for at least 20 seconds (I'd go 30)
4 - Reinstall CMOS battery.
5 - Plug PC back in.
6 - Cross fingers.
7 - Power on PC.

Other than that, you've tried far more than I can think of, so I'm kind of at a loss.


LOL, I'm not on mobile and I've accidentally done the same before.... no worries.

But, bummer. Seems like the board may be hosed somehow. Not sure I'd exactly blame the 7870, but can't really say - I'm out of my element at this point.