Question Just built my pc, and its refusing to post

Nov 30, 2021
4
0
10
0
Hello everyone i just built my new computer but it absoulotely refuses to post, the computer turns on fine but there is no signal on the monitor, i have tried everything, including removing cmoss battery then putting it back, reinstalling ram, reinstalling cpu, nothing works

Specs:
Asus Prime H410M-E
GeForce RTX 2060 6GB
Intel 11600K
2x 8GB G Skill Aegis 3000 C16 SC
Seagate Barracude 1TB Hard Drive
PSU: Fourze PS550

Any help will be greatly appreciated
 

DSzymborski

Titan
Moderator
First off, this never would have worked. If you go to the page for the motherboard and check the CPU support list -- really the first thing you do before you buy a motherboard -- you'll find that there's no support on this motherboard for any 11th generation Intel processor.

That's because H410 (and B460) motherboards explicitly don't support 11th generation Intel processors. You have to use a Z490 or H470 motherboard.

https://www.intel.com/content/www/us/en/support/articles/000058324/processors/intel-core-processors.html

Also, to head off any problems while you're resolving this issue, you really should not be using these components with a horrifyingly cheaply made, group-regulated PSU from an off-brand. An RTX 2060 should never even be turned on with this PSU, so it's actually a bit of good luck that you didn't get the right motherboard.
 
Last edited:
Hello everyone i just built my new computer but it absoulotely refuses to post, the computer turns on fine but there is no signal on the monitor, i have tried everything, including removing cmoss battery then putting it back, reinstalling ram, reinstalling cpu, nothing works

Specs:
Asus Prime H410M-E
GeForce RTX 2060 6GB
Intel 11600K
2x 8GB G Skill Aegis 3000 C16 SC
Seagate Barracude 1TB Hard Drive
PSU: Fourze PS550

Any help will be greatly appreciated
You want a B560 board with decent VRM's for that unlocked cpu.
 

ASK THE COMMUNITY

TRENDING THREADS