Question Keyboard disconnects when plugged into a usb hub (even powered hub) only on my main PC

Dec 22, 2020
1
0
10
0
So a little bit of background, since I've been trying pretty much everything.

I re-built a new PC pretty much from scratch, only keeping my Trident Z Ram (32 gb 3200 mhz, 4 sticks) and I've been having an issue when I plug my keyboard into a usb hub or usb switcher, I need this to work on my usb switcher since I'm sharing my peripherals between my gaming pc and work laptop.

My keyboard (Steelseries APEX PRO) disconnects randomly but more importantly it consistently disconnects when I start sharing my screen on discord, this does not happen when the keyboard is directly plugged into the motherboard's usb inputs.
My initial suspicion was the PSU, since I was running a ryzen 9 5900x, 3080 FE 4 sticks of ram with RGB and a buttload of RGB (case, keyboard, kraken x63 cooler) with a 750W PSU, I upgraded to a 1000W PSU, issue persists.
After that I figured maybe the motherboard was defective, so I returned my MSI x570 Gaming Edge Wifi for an asus TUF x570, issue persists, I also reinstalled windows and applied latest updates and no dice.

The weird thing is this issue only happens on my main desktop PC, the USB switch is also connected into my work laptop's dock running windows and I tried streaming discord at the same resolution (3440x1440) and had no issues whatsoever.
Then my suspicion was maybe both the USB Switcher and the USB hub were defective so I bought a better more expensive one and issue persists.

After that I tried buying a powered USB hub, thinking maybe power delivery through the USB might not be enough and same thing happens.

My last attempt was installing Ubuntu into my main PC and that worked perfectly, I was able to stream my discord screen without the keyboard disconnecting, so the one variable left is windows drivers.

Is there any other troubleshooting step that I might be missing? I did notice my work laptop has a more previous driver version of the keyboard (SSHID.dll) but I can't roll back or install a specific version apparently, unless there's a way for me to use that dll.

Another way this would happen was when I was trying to take a screenshot on windows with Windows+Shift+S, but this hasn't been an issue anymore (maybe after an update?)

Any help would be appreciated!
 
start control panel->hardware and sound->device manager
find the section on universal serial bus controllers, find the hub, right mouse click,
find the power management tab and unclick
allow the computer to turn off this device to save power.

the device should wake up when you hit a key but it may not be getting its usb wakeup packet
so it just would not respond. this should prevent it from going to sleep in the first place.

you might be able to run cmd.exe as an admin then run
powercfg.exe /energy
and look at the report to see if there is anything useful.
 

ASK THE COMMUNITY