• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

Question Keyboard issue alt gr "stuck"

Feb 6, 2021
8
0
10
0
Hello, I just formatted my PC and I encountered this silly thing that is driving me crazy. At random times windows 10 thinks that the alt gr is pressed and I have to push it phisically once to be able to write again. It could happen every few minutes or after hours, it's really difficult to replicate voluntarily. A few hours ago I thought I discovered at least what triggered this behaviour, every time I was writing, on discord for example, and some app stole focus it happened, many many times, but then it stopped and happened again at random times.

What I have tried so far:

  • Changing keyboard, right now I have a Corsair K70, plugged in Logitech G11, same issue.
  • Changing USB slots from 3.0 to 2.0 and then back.
  • Changing windows 10 language, tried to switch keyboard layout many times.
  • Reinstall keyboard drivers
I'm running out of ideas and I don't even understand what trigger this issue, tried to search every thread about this but didn't help.
Every driver is updated and I'm running the same programs that I was using before the format.
 

hedwar2011

Distinguished
Dec 3, 2011
1,518
3
19,965
98
Typically the "AltGr" key is enabled by default in Windows 10 but that's not to say it can't misbehave. When it doesn't work, does pressing Shift+Ctrl seem to make it work again correctly?

There is more info on the functionality and the different things to try HERE
 
Feb 6, 2021
8
0
10
0
I managed to fix that behaviour reinstalling keyboard, mouse and USB drivers and swapping usb slots another time, now I have another problem where If I leave my keyboard and mouse in the USB 3.0 ports (and they should be there according to razer and corsair) they don't work half the time, I also get the message "no keyboard detected" when I turn up my PC.

I think this is probably hardware issue, maybe my mobo or the USB 3.0 ports are faulty, not sure about it. Will try to test more if the USB 2.0 ports have the same problem, need a bit of time.
 

ASK THE COMMUNITY

TRENDING THREADS