Question Kingfast HDD loading but freezing Windows ?

Sep 8, 2022
3
0
10
0
Hello

I have a problem with my SSD (Kingfast Model: F6PRO 240GB). This HDD was previously on an older computer I had.
I tried connecting it to my computer with an external disc reader, they disc loads up but once I try to go into the files it begins to take time to load to the point it will freeze the computer and then I can't do anything.

I took the disc to a repair-store, they said only an specialized Data Recovery store could recover the files, long story short I do not have almost 400€ to fix it. (The repair-store only tried looking at it with a software on windows and they used linux to try to pick up the data but no success)

I'm trying to see if I could fix it myself. So far this is what I tried.

  • A few data recovery softwares (Nothing happened)
  • Connected to my older computer (internally): Hard Drive not found.
  • I opened it up and I try checking the capacitors with a multimeter (I do admit that I am learning by myself, so I'm not a master using it, meaning I don't know if I'm using the right settings to identify a possible shortcircuit )
- I got what I identify as a short on a connector.
- The multimeter bips constantly and I get a reading of 002 when I check the capacitor (L4 see picture)
- I loaded 3 Pictures here (https://postimg.cc/gallery/SNcgt3w)

I do not know if I'm on the right path of identifying the possible problem. Does any of you has a suggestion of the course of action or possible test that I could try?
I do not know if I should adventure into replacing the cap before trying something else.

In any case, thank you for taking the time to read my post and thank you in advance.

Cheers!
Magne
 
Last edited by a moderator:
Sep 8, 2022
3
0
10
0
L4 looks like a polyswitch or fuse. These would normally have a resistance of 0 ohms. You should measure +5V on each side.
Thank you for taking the time to reply. I know that is up to me but would you recommend trying replacing that fuse/ polyswitch / capacitor? Also, was the setting that I used on the multimeter correct? (My apologies for my lack of knowledge I'm learning).

I was also cheeking to buy a replacement but I'm not sure which I have to buy, I see so many different types (NF,UF, PF). Is there a way to identify the one I need? (I'm checking at the moment to see if I manage to point out the one I need).

Thanks in advance
 
Last edited:
If "L4" reads 0.0 ohms on the 200 ohms scale, or if it beeps on the diode scale, then it is OK.

There is one thing you could try, but it won't give you access to your data. These SSDs normally have "ROM mode" test points. In the bottom left corner of your first photo there is a screw hole. Immediately above this hole are two test points, one with a square pad, the other with a round pad. I suspect that these are the ROM mode test points. If you short these points with tweezers while applying power to the SSD, the SSD should identify itself as a Silicon Motion product rather than Kingfast. This will tell us that the flash controller is working, and that the problem is most likely a firmware "panic". Note that you only need to short the ROM mode points until the SSD has powered up, then you can release the short.

This is a different Silicon Motion SSD, but you can see the same ROM mode test points (the other test points are probably for debugging via JTAG):

http://vlo.name:3000/hw/ssd/pcb/smi/ne-120-pcb0.jpg

This is a typical ROM mode ID:

http://vlo.name:3000/hw/ssd/rommode/sm2258xt_rom.png
 
Last edited:

jeremy0118

Honorable
Feb 29, 2016
164
15
10,615
7
Kingfast is like all of those aliexpress ssds kingdian kingspec. they are all <Mod Edit>. no way to read health. completely unknown as to the components used. they die randomly

Always make backups to multiple devices, and buy ssds from reputable brands. even the most basic kingston a400 drive is far more reliable than that crap. Let it be a lesson.

As to what you can do. idk. doubt these files can be saved. what this pc store tells is useless speculation unless they opened up the ssd and were able to identify a broken controller. controllers die all the time in these garbage tier ssds. maybe with the right tools this can be replaced but what do i know. Sorry to hear about this.
 
Last edited by a moderator:

ASK THE COMMUNITY