Question Lag in Gaming and E2100 Error 1603

Jul 31, 2019
14
2
15
0
I recently installed some new hardware and in the process removed a fully functional and working Thunderbolt card which came with the motherboard (a Rampage III Black Edition). The card features a Bigfoot Killer E2100 (Ethernet) component. Over the next few days I was hit with terrible FPS rates and crazy lag every time playing large scale MMO action and wondered if I ought not to reinstall the card, and set up my Ethernet as before, with two connections, the main Intel connection, and a second Bigfoot Killer E2100 connection. I don't recall having lag like that ever before, and so on a second system I tested game play, and did not witness any remotely similar trouble.

After reinstalling the card (and seeing it working--with even the internet cable end lit on connecting) I found the software needed (as I had uninstalled it) on (1) the original motherboard CD, (2) the support page for the motherboard, and (3) another website, but then for hours was faced with the "Fatal error 1603" just prior to installation completion--even when trying various compatibility settings. I then tried getting the hardware in device manager to try to install drivers--even searching on an old hard drive where the software worked and is installed (this worked once before) but nothing would get the card/connection working again.

I have had similar problems before when installing a new SSD, newer versions of Windows, etc. but have never had so much difficulty after hours of effort and various things. If anyone can offer some suggestions for how to get this thing working, that would be a great help.

Edit: Problem solved with this: https://www.drivereasy.com/knowledge/error-1603-fatal-error-during-installation-fixed/
 
Last edited:
Not sure what you ended up with as a configuration but you want to be sure that any of that killer gamer software is not on your machines. They have a history of massive issues with their drivers. You want to download the drivers from the killer site that all the killer features removed.
 
Jul 31, 2019
14
2
15
0
Thanks for your reply. I got a package from Asus for the motherboard installed and don't use the software features at all--I know at least some of them don't work. The drivers were no longer available at Bigfoot/Killer or another website where they had set up a link to. I emailed them at the stage when nothing would install and after getting the software from Asus to install Bigfoot/Killer sent me something to install, but since I got the card working I may not mess around with anything.

Do you have experience with the card yourself? Since it seems to be working fine, I may just leave it be. Do you have a link to the driver without features for their E2100? They seem to have completely dropped support (at least if you dont email them).
 

ASK THE COMMUNITY