Question Lagging after a few minutes with games - Acer Nitro 5 AN515-57-59F7 (i5 11th Gen 11400H + Rtx 3050 )

Oct 31, 2022
2
0
10
0
Hi all, apologies if this is not the right place for this.

Recently I bought the Acer Nitro 5 AN515-57-59F7 (i5 11th Gen 11400H + Rtx 3050 ) , used it for about a month, played Elden Ring, Gta V, Minecraft, Overwatch 2 and other titles alike and they all worked fine however a day after I restored the computer and gave it to my cousin after a few minutes playing any title the whole pc starts to lag, its not overheating nor is the cpu/gpu being used 100%, temps are usually around 65C-80C. Funny part is if we restart the computer or just simply close it wait for it to go to sleep and open it again it's normal again, and after a few minutes it starts to lag again. at this point we have formatted the PC, updated all the drivers again however the issue still persists.

In Msi Afterburner the CPU load when it starts to lag goes to 100% however in task manager its like the CPU isn't being used at all (Don't know if this information is of any value). Besides the Initial formatting I did when I got the laptop and the factory reset nothing else was done to the laptop.

Hope anyone can give me an insight. thank you very much and apologies for my English, its my second language.

Edit: Playing Minecraft with a few mods does not seem to activate the problem. however as soon as another game is loaded it took 5min.
 
Last edited:

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

a day after I restored the computer and gave it to my cousin
+
if we restart the computer or just simply close it wait for it to go to sleep and open it again it's normal again, and after a few minutes it starts to lag again

You should've reinstalled the OS using a bootable USB installer for the OS, using Windows Media Creation Tools.

updated all the drivers again however the issue still persists.
Did you manually install all drivers for your laptop or did you let the OS source drivers it thinks is right for your laptop?

Check and see if your laptop has any BIOS updates pending. I'm assuming you're working with Microsoft's Windows OS, if not, please state what OS you're on and if Windows, which version you're on.
 
Oct 31, 2022
2
0
10
0
Welcome to the forums, newcomer!

a day after I restored the computer and gave it to my cousin
+
if we restart the computer or just simply close it wait for it to go to sleep and open it again it's normal again, and after a few minutes it starts to lag again

You should've reinstalled the OS using a bootable USB installer for the OS, using Windows Media Creation Tools.

updated all the drivers again however the issue still persists.
Did you manually install all drivers for your laptop or did you let the OS source drivers it thinks is right for your laptop?

Check and see if your laptop has any BIOS updates pending. I'm assuming you're working with Microsoft's Windows OS, if not, please state what OS you're on and if Windows, which version you're on.
Hi and thank you for the response.

We updated all the drivers ( VGA drivers/Chipset and etc manually). Yes using win 10, used the windows media creation tool to format the computer ( Not the USB stick option the one that does it without needing the USB)

On the bios side I never updated them, when the pc was working fine and haven't updated them however we will look into updating it.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts