Question Laggy BIOS

Aug 11, 2020
2
0
10
0
Hey, I have a problem. I safely unplugged my PC this morning and when I plugged it back in I checked the BIOS. I noticed about every 5 seconds the BIOS screen would freeze for a few seconds. I then tried opening several game and in the game my audio would cut out for like 2 seconds every 10 seconds. Additional, my game would also freeze at times. I would have 70+ FPS then it would drop to 1 FPS then it would spike back up to 70+ FPS.

I already updated the BIOS and chipset hoping that would fix it but it didnt. I can run youtube and windows completely fine. I built my system about a year ago.

I need help!
Thanks

Specs:

Ryzen 5 2600x
Asus Prime b450 Plus
Corsair Veneance 8gb DDR4 3000mhz (My other ram stick had problems)
Gigabyte GTX 1650
EVGA 500 BR
 
Last edited:

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Which BIOS version are you on at the moment? Which version of Windows 10 are you working with? How old is that PSU? When you speak of the other ram stick having problems, did you try another stick of ram for your build? Also, which slot are you populating on your build?
 
Aug 11, 2020
2
0
10
0
I am currently using American Megatrends Inc. 2202, 7/14/2020, which I updated yesterday while I was troubleshooting. I am using windows 10. I bought my PSU in August of last year. A few months ago I was getting blue screens and traced it back to a faulty ram stick. My single ram stick is in A2, which the manual says if I am only using one ram stick.
 
Thread starter Similar threads Forum Replies Date
L Motherboards 3

ASK THE COMMUNITY

TRENDING THREADS