• Hey there, Guest! Share your idea for a new trophy in the forums and win bragging rights and a $100 Amazon gift card! Check out the New Community Trophy Contest here!
  • Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

Lan driver for x299 motherboard wont install

MrHiddeS

Reputable
Jun 17, 2015
41
0
4,540
3
Hello,

Today I got my new motherboard asus TUF x299 Mark 2 with an i7 7800x and ddr4 ram.
I installed a fresh and clean windows 10 on my boot drive.
After succesfully installing the motherboard drivers from the disk I noticed that when I started the setup again that the lan driver was not installed, it was unchecked. I select it and try to install again, still doesnt install, no internet.

I have tried installing the latest LAN driver by downloading it from http:// on my laptop and puting it on the pc by flash drive. When I try to install it that way I get an error saying that there is not intel adapter on the computer.

I tried installing the chipset from the same website as mentiond before and this just simply wont start installing at all, it just says install failed.

I tried installing the x299 chipset from intels website http://
This says install was succesful but I stil cant install the lan drivers.

I even installed windows 10 again but still nothing.

I tried updating the bios from the same website as mentiond first, still nothing.

I am at a loss here anyone know what to do? I found multiple threads about this issue with different chipsets and all their solutions dont seem to work for me.
 

NTIGeek

Honorable
Oct 14, 2013
25
0
10,540
3


Mr Hiddes just wanted to say thank you for posting this. Drove me nuts for 2 days, Asus support was clueless about it. Connected a USB WiFi stick, did windows updates, automatically installed the LAN drivers. DONE.

Thanks for taking the time to post it, it helped me today.
Len

 

Similar threads