Question Laptop blue screens when installing Hyper-V ?

Short version
I previously had Hyper-V installed and working on this laptop. Unfortunately the host OS got into an update boot loop. Windows would download the update, reboot to install, the install would fail. Repeat. Over and over (pausing only during my active hours). After failing at diagnosing the cause, I bit the bullet and reset the laptop to factory default. That fixed the update problem, but now every time I try to install Hyper-V it blue screens every reboot. The only way I can recover to a working system is system restore, or another factory reset.

Long version

HP Omen laptop
AMD R7 4800H
512 GB SSD
Windows 10 Pro (upgraded from Win 10 Home).

I originally got this to play games on. But eventually decided to retire my 10-year old server and move my VMs to the laptop. Added more RAM, and upgraded the license to Pro to get access to Hyper-V.

The SSD was originally configured with just a C: partition. I used a partition manager to resize that and create a D: partition. That way I could add a second SSD in the future and just copy the partition over instead of having to reconfigure all my software settings.

I believe the update problem happened about the same time because (unknown to me at the time) the recovery environment also stopped working. I've encountered and solved failed updates before, so figured I'd deal with it later. I went ahead and installed Hyper-V, which went off without a hitch. I installed two VMs, and they ran without problems for two weeks.

The update problem proved to be tenacious (a permanent red "Windows is missing important security features" message). The first week it was just a red message. But the second week a required major Windows update rolled out. After that, the host OS began rebooting overnight. (I realize it's not really a host, and that Hyper-V installs a hypervisor. I'm just trying to explain what happened.)

While trying to find a solution to the update problem, I tried to get into the recovery environment to try messing with the UEFI settings. That's when I discovered the recovery environment no longer worked (or rather, Windows couldn't find it). Interestingly, Windows Pro would automatically reboot to try to install the update (and fail), even though I disabled automatic reboots upon updating.

I was out of ideas. So I backed everything up, removed the D: partition, and reset Windows to factory default (which worked even though the data for it was in the recovery partition). After the factory reset, everything seemed to be working. The recovery environment began working again,, and Windows installed all available updates with no failures.

Then I tried installing (activating) Hyper-V to finish this off. That's when I found it would continuously blue-screen upon rebooting to complete the install. I have tried:
  • Installing Hyper-V via the Add Windows Features box.
  • Installing Hyper-V via an admin command prompt.
  • Installing just the Hyper-V platform instead of the full package.
  • Another factory reset, and installing Hyper-V immediately after the factory reset (before any updates).
  • A factory reset downloading Windows, instead of getting it off the recovery partition.
No change. I install/activate Hyper-V, and every reboot afterwards blue screens. Eventually throwing me into the recovery environment, where I can use system restore or do a factory reset to get back to a usable system (without Hyper-V).

I'm guessing the problem is with the hypervisor. Some vestige of the previous hypervisor is probably hanging around, and screwing things up when Hyper-V tries to install the hypervisor again. But I haven't a clue how to go about diagnosing or fixing that. Microsoft did some voodoo magic to make it seem like Hyper-V was running from a host, when it's really running from a hypervisor.

Any help or suggestions would be appreciated. I would prefer to reinstall Windows off of USB (losing the HP drivers and software) only as a last resort.
Last edited by a moderator:
Finally figured this out. My mistake was assuming I somehow caused this. It turns out to be a bug Microsoft introduced in 2020. Windows 10 build 1909 (what I was running when I successfully installed Hyper-V) did not have this bug. Build 2004 or 20H2 introduced the bug, and it's still present in 21H1.

The bug is a conflict between Hyper-V's installation process and AMD's integrated graphics drivers (so it only affects Ryzen systems). Suggested fixes included:
  • Uninstall the AMD video drivers, install Hyper-V, and update the AMD video drivers.
  • Assigning 1 GB of RAM in the BIOS to AMD's integrated graphics. (WTF? But it seems to work.)
  • Wait for your vendor to put out a new BIOS, as some of the BIOSes in testing are reported to have fixed the problem.
I checked and HP had just put out a new BIOS (I already updated it before I made my first post here). Installed that, updated to the latest AMD drivers for good measure, and that did the trick. Hyper-V is back up and running
Hyper V sucks anyway download and use VMware player

Hyper V is the most backwards and crappiest of all VM software
I actually own VMWare Workstation. I'm experimenting with Hyper-V because I'm having problems with VMWare VMs randomly losing network connectivity (I have to manually disable and re-enable the network to fix it), and the VMWare process randomly spiking CPU usage to 100% for about 15 seconds for no apparent reason.