Mar 18, 2023
Hello. I have a HP TPN C126 laptop (15-af106nt) in my hand right now. It used to work fine, but then suddenly it didn’t boot the windows 10 that's on the hard disk, and the screen just goes dark gray and stays like that forever.

When I tried booting from 2 different usb sticks (one has ventoy, the other has linux mint for a fun wii project), same issue happened. However, the sticks were blinking (access light) so, the computer at least tries something but can’t boot nor display an error. Hard disk works fine by the way, it is not the issue here. I checked it and use it for my backups now.

I can access all bios features and built in diagnostics tool: hard drive and ram passed, I tried with a different ram anyway and it also passed. One exception that doesn’t work is the F10 key I think, which is recovery mode. It causes the same error explained above.

The boot manager can see my usb sticks, I can browse the sticks using “boot from efi file” option. Obviously, it won’t boot. Same error explained above.

I removed the cmos battery for 1-2 hours, then plugged it back. The pc said that cmos checksum mismatched and it would reset the settings, and did what it said (I checked bios, date was set back to 2015). Obviously, this didn’t fix the computer’s “I wont boot anything, I wont tell any errors” policy.

I got myself a clean flash usb and used the HP bios update tool from a working computer to make it a bios update flash. I plugged it in, tried all options in boot manager and of course, same error as above.

This is literally my computer not booting anything no matter what and only working fine with bios and built in diagnostics tool and system information (which is accessible by F1).

What could be wrong? Is it something I can find out at home? Is its motherboard a synonym of “trash”? Or is trash more useful than the motherboard? Thank you for any help in advance.